<!doctype html>
      <html class="single desktop layout-clean fixed-full-width" lang="en">
        <head>
          <title>These Are the 10 Most Hated Roundabouts in the Boise Area</title>
          <meta http-equiv="Content-Type" content="text/html;charset=UTF-8"/><meta charset="UTF-8"/><meta name="instagram_profile" value="1079litefm"/><meta name="description" content="Did you know Boise didn&#x27;t have a roundabout until 2006? It&#x27;s taken us 15 years to make up for lost time."/><meta name="keywords" content="worst roundabouts in boise, new roundabouts in boise, where did that roundabout come from, where was idaho&#x27;s first roundabout?,local news"/><meta property="fb:app_id" content="151245606939829"/><meta property="fb:admins" content="100002025987268"/><meta property="fb:use_automatic_ad_placement" content="false"/><meta property="og:title" content="These Are the 10 Most Hated Roundabouts in the Boise Area"/><meta property="og:description" content="Did you know Boise didn&#x27;t have a roundabout until 2006? It&#x27;s taken us 15 years to make up for lost time."/><meta property="og:url" content="https://liteonline.com/these-are-the-10-most-hated-roundabouts-in-the-treasure-valley/"/><meta property="og:site_name" content="107.9 LITE FM"/><meta property="og:type" content="article"/><meta property="og:image:width" content="1200"/><meta property="og:image:height" content="630"/><meta property="og:image" content="https://townsquare.media/site/660/files/2021/07/attachment-Parkcenter.jpg?w=1200&#x26;h=0&#x26;zc=1&#x26;s=0&#x26;a=t&#x26;q=89"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@1079litefm"/><meta name="sailthru.description" content="Did you know Boise didn&#x27;t have a roundabout until 2006? It&#x27;s taken us 15 years to make up for lost time."/><meta name="sailthru.date" content="2021-07-16 13:22:35"/><meta name="sailthru.title" content="These Are the 10 Most Hated Roundabouts in the Treasure Valley"/><meta name="sailthru.tags" content="tsmsite-kxlt, tsmmarket-boise, tsmtype-local, construction, growth, newsletter, traffic, local-news"/><meta name="sailthru.author" content="michelleheart"/><meta name="sailthru.image.full" content="https://townsquare.media/site/660/files/2021/07/attachment-Parkcenter.jpg"/><meta name="sailthru.image.thumb" content="https://townsquare.media/site/660/files/2021/07/attachment-Parkcenter.jpg"/><meta name="robots" content="max-image-preview:large"/><meta property="fb:pages" content="138647476157057"/>
          <link rel="preload" href="/styles/desktop/base.css?ver=7de44a93c6ab86b5f8800facee2078010e182b63&mver=102&gver=3" as="style"/><link rel="preload" href="//townsquare.media/public/dist/desktop/main.bundle.7de44a93c6ab86b5f8800facee2078010e182b63.js?mver=102&gver=3" as="script"/><link rel="preconnect" href="https://btloader.com" crossorigin /><link rel="preconnect" href="https://action.dstillery.com" crossorigin /><link rel="preconnect" href="https://cdn.taboola.com" crossorigin />
          <link id="design-fav" rel="shortcut icon" href="https://townsquare.media/site/660/files/2018/03/LiteFavilogo1.gif"/><link rel="profile" href="http://gmpg.org/xfn/11"/><link rel="prev" title="The Top Youtube Videos That Come Up When You Search ‘Boise, ID’" href="https://liteonline.com/the-top-youtube-videos-that-come-up-when-you-search-boise-id/"/><link rel="next" title="Enjoy The Heat, Boise; Winter Projections Are Looking Brutal" href="https://liteonline.com/enjoy-the-heat-boise-winter-projections-are-looking-brutal/"/><link rel="canonical" href="https://liteonline.com/these-are-the-10-most-hated-roundabouts-in-the-treasure-valley/"/><link rel="apple-touch-icon-precomposed" href="https://townsquare.media/wp-content/uploads/2019/05/KXLTFM.png?w=57&h=57"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://townsquare.media/wp-content/uploads/2019/05/KXLTFM.png?w=144&h=144"/><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://townsquare.media/wp-content/uploads/2019/05/KXLTFM.png?w=72&h=72"/>
          <!-- <link href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap" rel="stylesheet" type="text/css" /> -->
          <!-- connect to domain of font files -->
          <link rel="preconnect" href="https://fonts.googleapis.com" crossorigin/>
          <!-- optionally increase loading priority -->
          <link rel="preload" as="style" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap">
          <!-- async CSS -->
          <link rel="stylesheet" media="print" onload="this.onload=null;this.removeAttribute('media');" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap">
          <!-- no-JS fallback -->
          <noscript>
            <link rel="stylesheet" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap">
          </noscript>
          <link href="/styles/desktop/base.css?ver=7de44a93c6ab86b5f8800facee2078010e182b63&mver=102&gver=3" rel="stylesheet" type="text/css" />
          <script>window.TSM = window.TSM ||{}; window.TSM.fn = window.TSM.fn || {}; window.TSM.fn.isIe = function(n){var t,i;return(n=n||"",!n||n===null||typeof n=="undefined"||n&&!n.match)?!1:(t=n.match(/MSIEs([d.]+)/i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):(t=n.match(/Trident.*rv[ :]*(11)./i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):!1};
      window.TSM.fn.getFile=function(n,t={},i=document.body){return new Promise(function(r){var e=function(n){n.target.removeEventListener("load",e);r(n.target)},u=document.createElement("script"),f;u.addEventListener("load",e);u.src=n;for(f in t)u.setAttribute(f,t[f]);i.appendChild(u)})};
      window.TSM.fn.getCookie = window.TSM.fn.getCookie || function(n){var i="; "+document.cookie,t=i.split("; "+n+"=");if(t.length==2)return t.pop().split(";").shift()};
      window.TSM.fn.setCookie = window.TSM.fn.setCookie || function(n,t,i,r="/"){var f="",u;i&&(u=new Date,u.setTime(u.getTime()+i*864e5),f="; expires="+u.toUTCString());document.cookie=n+"="+(t||"")+f+"; path="+r};
    </script>
          <script>window.taskQ=[];</script>
          
        <script type="text/javascript">
          window.TSM = window.TSM || {q:[]};
          window.TSM.abgroup = "B";
          window.TSM.cadata = {"activeDomain":"liteonline.com","blogId":660,"method":"get_single","postId":162978,"postType":"post","postDateGmt":"2021-07-16 19:22:35.000+0000"};
          window.TSM.startload = new Date().getTime();
        </script>
          <script>
    (function () {
      function getCookie(name) {
        var value = "; " + document.cookie;
        var parts = value.split("; " + name + "=");
        if (parts.length == 2) return parts.pop().split(";").shift();
      }
      function updateCookie(name, value, expireDays) {
        let d = new Date();
        d.setTime(d.getTime() + (60*60*24*expireDays*1000));
        var expires = "expires="+ d.toUTCString();
        document.cookie = name + "=" + value + ";" + expires + ";path=/";
      }
      window.TSM = window.TSM || {};
      if (window.TSM.abgroup) {
        updateCookie("abgroup", window.TSM.abgroup, 90);
      }

      var xhr = new XMLHttpRequest();
      xhr.open("POST", "/rest/high/api/cogitoergosum", true);
      var cogitoergosum = getCookie("cogitoergosum");
      var abgroup = getCookie("abgroup");
      if (cogitoergosum) {
        window.TSM.cogitoergosum = JSON.parse( atob( decodeURIComponent( cogitoergosum ) ) );
      }
      xhr.onreadystatechange = function() {//Call a function when the state changes.
        if(xhr.readyState == XMLHttpRequest.DONE && xhr.status == 200) {
          if (xhr.response) {
            var result = JSON.parse(xhr.response);
            if (result && result.result) {
              if (result.result.cookie) {
                window.TSM.cogitoergosum = JSON.parse( atob( result.result.cookie ) );
              }
              if (result.result.credentials) {
                window.TSM.credentials = JSON.parse( atob( result.result.credentials ) );
              }
              // console.log("cogitoergosum xhr", window.TSM.cogitoergosum);
            }
          }
        }
      };
      xhr.setRequestHeader("Content-type", "application/json");
      var cadata = window.TSM.cadata || {};
      cadata.experimentGroup = window.TSM.abgroup;
      cadata.viewType = "standard";
      cadata.timespent = new Date().getTime() - window.TSM.startload;
      var referrer = document.referrer;
      var sendData = {
        type: "pageview",
        referrer: referrer,
        url: document.location.href,
        queryParam: document.location.queryParam,
        pageData: cadata,
        scrollPageIndex: 0
      };
      xhr.send(JSON.stringify(sendData));
    }());
  </script>
          <script>(function(w,d){
        const
          getCookie = w.TSM.fn.getCookie;
        let
          aleph = getCookie( "aleph" );
        if( aleph ){
          w.aleph = aleph;
        }
      })(window, document);</script>
          <script>
            (function(w){
              w.ga=w.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
              var gaInitData = {"hitType":"pageview","dimension1":"michelleheart","dimension2":"local-news","dimension3":"construction,growth,newsletter,traffic","dimension4":"post","dimension5":"Fri Jul 16 2021","dimension6":"13:22","dimension7":"standard","dimension8":"805","dimension9":"B","dimension10":"yes","dimension12":"","dimension13":"","dimension14":"","dimension15":"","dimension16":""};
gaInitData.dimension13=function(){let refData=sessionStorage.getItem("itemRef"),str=[];return refData&&(refData=JSON.parse(refData),refData.title&&(str.push(refData.title),str.push(refData.source||"NA")),sessionStorage.removeItem("itemRef"),window.opener&&window.opener.sessionStorage&&window.opener.sessionStorage.removeItem("itemRef")),str.join(" -|- ");}();
gaInitData.dimension15=window.aleph || "";
gaInitData.dimension16=navigator.userAgent || "";
window.globalDimensionData = {"dimension1":"michelleheart","dimension2":"local-news","dimension3":"construction,growth,newsletter,traffic","dimension4":"post","dimension5":"Fri Jul 16 2021","dimension6":"13:22","dimension7":"standard","dimension8":"805","dimension9":"B","dimension10":"yes","dimension12":"","dimension13":"","dimension14":"","dimension15":"","dimension16":""};
window.globalDimensionData.dimension15=window.aleph || "";
ga( "create", {
          trackingId:"UA-45254601-8",
          name: "primary",
          allowAnchor: false
        });
        
        ga( "primary.require", "displayfeatures" );
        ga( "primary.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "primary.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "primary" ] = {gaid:"UA-45254601-8"};
ga( "create", {
          trackingId:"UA-19109753-1",
          name: "UA191097531",
          allowAnchor: false
        });
        
        ga( "UA191097531.require", "displayfeatures" );
        ga( "UA191097531.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA191097531.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA191097531" ] = {gaid:"UA-19109753-1"};
ga( "create", {
          trackingId:"UA-45254601-2",
          name: "UA452546012",
          allowAnchor: false
        });
        
        ga( "UA452546012.require", "displayfeatures" );
        ga( "UA452546012.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA452546012.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA452546012" ] = {gaid:"UA-45254601-2"};
ga( "create", {
          trackingId:"UA-28825804-1",
          name: "UA288258041",
          allowAnchor: false
        });
        
        ga( "UA288258041.require", "displayfeatures" );
        ga( "UA288258041.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA288258041.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA288258041" ] = {gaid:"UA-28825804-1"};
ga( "create", {
          trackingId:"UA-45260060-5",
          name: "UA452600605",
          allowAnchor: false
        });
        
        ga( "UA452600605.require", "displayfeatures" );
        ga( "UA452600605.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA452600605.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA452600605" ] = {gaid:"UA-45260060-5"};
ga( "create", {
          trackingId:"UA-180756957-2",
          name: "UA1807569572",
          allowAnchor: false
        });
        
        ga( "UA1807569572.require", "displayfeatures" );
        ga( "UA1807569572.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA1807569572.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA1807569572" ] = {gaid:"UA-180756957-2"};
            })(window);
          </script>
          <script async defer src="https://www.google-analytics.com/analytics.js"></script>
          <script async defer src="//townsquare.media/public/resources/js/autotrack.carbon.js"></script>
          <script>(function(w){
      w.dataLayer = [{"title":"These Are the 10 Most Hated Roundabouts in the Boise Area","callsign":"KXLTFM","market":"Boise","sitetype":"Local","siteClassification":"Local","state":"ID","genre":"pop,classic-hits","pageType":"post","tags":"construction,growth,newsletter,traffic","categories":"local-news","mediaType":"gallery","aleph":"","userAgent":"","GaIds":"G-0KDQ4QRFNQ","GaPrimaryId":"G-0KDQ4QRFNQ","GaMarketRollupId":"","GaCompanyRollupId":"","GaRegionRollupId":"","GaStationRollupId":"","author":"michelleheart","postDateGmt":"2021-07-16 19:22:35.000+0000"}];
      w.dataLayer[0].referer = document.referrer;w.dataLayer[0].curatedReferer = document.referrer.replace( /https?:\/\//, "" );w.dataLayer[0].dayOfWeek = function(n){return n.toLocaleString("en-US",{weekday:"long"})}(new Date);w.dataLayer[0].periodOfDay = function(n,t,i){t=n.getHours(),i=n.getMinutes(),i<10&&(i="0"+i);var r=parseInt(t+""+i);return r>=0&&r<600?"Overnight":r>=600&&r<1e3?"Morning Drive":r>=1e3&&r<1500?"Midday":r>=1500&&r<1900?"Afternoon Drive":r>=1900&&r<2400?"Evening":void 0}(new Date);w.dataLayer[0].userAgent = navigator.userAgent;
    })(window);</script>
          <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start": new Date().getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!="dataLayer"?"&l="+l:"";j.async=true;j.src= "https://www.googletagmanager.com/gtm.js?id="+i+dl;f.parentNode.insertBefore(j,f); })(window,document,"script","dataLayer","GTM-K346HJZ");</script>
          
        
        
        
        
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
      (function (d, t) {
        var g = d.createElement(t), s = d.getElementsByTagName(t)[0];
        g.type='text/javascript';
        g.async = true;
        g.defer = true;
        g.src = 'https://btloader.com/tag?o=5642230212591616&upapi=true';
        s.parentNode.insertBefore(g, s)
      }(document, 'script'));
    });</script>
        
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
        window.TSM.fn.getFile("https://action.dstillery.com/orbserv/nsjs?adv=cl1016361&ns=3141&nc=KXLTFM&ncv=24", {"async": "async", "defer": "defer"});
        window.TSM.fn.getFile("https://action.dstillery.com/orbserv/nsjs?adv=cl1016361&ns=3141&nc=all_tsm_sv&ncv=24", {"async": "async", "defer": "defer"});
      });</script>
        
        
        
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
      (function (d, t) {
        var g = d.createElement(t), s = d.getElementsByTagName(t)[0];
        g.type='text/javascript';
        g.async = true;
        g.defer = true;
        g.src = '//townsquare.media/public/resources/js/pubcid.min.js';
        s.parentNode.insertBefore(g, s)
      }(document, 'script'));
    });</script>
          
          
          <script>//gdpr 2 - tcfapi stub
      ;!function(){var e=function(){var e,t="__tcfapiLocator",a=[],n=window;for(;n;){try{if(n.frames[t]){e=n;break}}catch(e){}if(n===window.top)break;n=n.parent}e||(!function e(){var a=n.document,r=!!n.frames[t];if(!r)if(a.body){var i=a.createElement("iframe");i.style.cssText="display:none",i.name=t,a.body.appendChild(i)}else setTimeout(e,5);return!r}(),n.__tcfapi=function(){for(var e,t=arguments.length,n=new Array(t),r=0;r<t;r++)n[r]=arguments[r];if(!n.length)return a;if("setGdprApplies"===n[0])n.length>3&&2===parseInt(n[1],10)&&"boolean"==typeof n[3]&&(e=n[3],"function"==typeof n[2]&&n[2]("set",!0));else if("ping"===n[0]){var i={gdprApplies:e,cmpLoaded:!1,cmpStatus:"stub"};"function"==typeof n[2]&&n[2](i)}else a.push(n)},n.addEventListener("message",(function(e){var t="string"==typeof e.data,a={};try{a=t?JSON.parse(e.data):e.data}catch(e){}var n=a.__tcfapiCall;n&&window.__tcfapi(n.command,n.version,(function(a,r){var i={__tcfapiReturn:{returnValue:a,success:r,callId:n.callId}};t&&(i=JSON.stringify(i)),e.source.postMessage(i,"*")}),n.parameter)}),!1))};"undefined"!=typeof module?module.exports=e:e()}();</script><script>
      window.cmpFactory = function( varName ) {
        var
          listen = window.attachEvent || window.addEventListener,
          isDebug = RegExp( "debug=([^&]+)" ).exec( location.search );
        listen('message', function(event) {
          window[ varName ].receiveMessage && window[ varName ].receiveMessage(event);
        });

        var commandQueue = [];
        var cmp = function(command, parameter, callback) {
          if( command === "ping" ){
            callback({cmpLoaded: false}, true);
          }else{
            commandQueue.push({
              command: command,
              parameter: parameter,
              callback: callback
            });
          }
        };
        cmp.commandQueue = commandQueue;
        cmp.receiveMessage = function(event) {
          var data = event && event.data && event.data[ varName + "Call" ];
          if (data) {
            commandQueue.push({
              callId: data.callId,
              command: data.command,
              parameter: data.parameter,
              event: event
            });
          }
        };
        cmp.config = {};
        if( isDebug && isDebug[1] && isDebug[1] === "YES" ){
          cmp.config.logging = "debug";
        }
        return cmp;
      };
      window.__cmp = window.cmpFactory( "__cmp" );
      window.__uspapi = window.cmpFactory( "__uspapi" );
    </script><script>
      (function(w) {
        w.TSM.fn.getFile( "//townsquare.media/public/resources/js/cmp.bundle.js", {}, document.head );
        w.cnvr_launcher_options={lid:336};
        w.TSM.fn.getFile( "https://secure.cdn.fastclick.net/js/cnvr-launcher/latest/launcher-stub.min.js", {}, document.head );
      })(window);
    </script>
          <link rel="preconnect" href="https://doi3unldljdx6.cloudfront.net." crossorigin/><script type="text/javascript" src="//doi3unldljdx6.cloudfront.net./script.js" async></script><script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
        <script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        </script>
<script async src="//js-sec.indexww.com/ht/p/186854-113710634486999.js"></script>
<script>window.pbjs=window.pbjs||{};window.pbjs.que=window.pbjs.que||[];window.PREBID_TIMEOUT=2000;</script>
<script src="https://cdn.production.townsquareblogs.com/wp-content/uploads/static/prebid/carbon/pb.js?domain=liteonline.com&v=7de44a93c6ab86b5f8800facee2078010e182b63&mver=102&gver=3" ></script>

<script>(function(){!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
        var params={pubID:"3227",adServer:"googletag",params:{us_privacy: (RegExp( "usprivacy=([^;]+)" ).exec( document.cookie ) || [])[1] || "1---"}};apstag.init(params);})();</script>


<script>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</script>
          <script defer src="https://apis.google.com/js/platform.js"></script>
      <script>window.twttr = (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0],
        t = window.twttr || {};
      if (d.getElementById(id)) return t;
      js = d.createElement(s);
      js.id = id;
      js.src = "https://platform.twitter.com/widgets.js";
      fjs.parentNode.insertBefore(js, fjs);
      t._e = [];
      t.ready = function(f) {
        t._e.push(f);
      };
      return t;
    }(document, "script", "twitter-wjs"));
    (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id;
      js.src = "//connect.facebook.net/en_US/sdk.js";
      fjs.parentNode.insertBefore(js, fjs);
    }(document, "script", "facebook-jssdk"));</script>
    <script async defer src="//platform.instagram.com/en_US/embeds.js"></script>
    <script type="text/javascript" async defer src="//assets.pinterest.com/js/pinit.js"></script>
    <script>var ZERG = ZERG || {};ZERG.domain = "liteonline.com";ZERG.user = 751;</script>
          <script type="text/javascript">
      window._taboola = window._taboola || [];
        _taboola.push({article:"auto"});
        !function (e, f, u, i) {
          if (!document.getElementById(i)){
            e.async = 1;
            e.src = u;
            e.id = i;
            f.parentNode.insertBefore(e, f);
          }
        }(document.createElement("script"),
          document.getElementsByTagName("script")[0],
          "//cdn.taboola.com/libtrc/townsquaremediatsm-network/loader.js",
          "tb_loader_script");
        if(window.performance && typeof window.performance.mark == "function")
        {window.performance.mark("tbl_ic");}
    </script>
          <script type="application/ld+json">{"@context":"https://schema.org","@graph":[{"@context":"https://schema.org/","@type":"NewsMediaOrganization","@id":"https://liteonline.com/#organization","name":"107.9 LITE FM","logo":{"@type":"ImageObject","@id":"https://liteonline.com/#sitelogo","url":"//townsquare.media/site/660/files/2015/11/logo.png"},"sameAs":["https://liteonline.com/"]},{"@context":"http://schema.org/","@type":"Website","@id":"https://liteonline.com/#website","publisher":{"@id":"https://liteonline.com/#organization"},"name":"107.9 LITE FM","url":"https://liteonline.com/"},{"@context":"https://schema.org","@type":"article","headline":"These Are the 10 Most Hated Roundabouts in the Treasure Valley","publisher":{"@id":"https://liteonline.com/#organization"},"url":"https://liteonline.com/these-are-the-10-most-hated-roundabouts-in-the-treasure-valley/","mainEntityOfPage":{"@type":"WebPage","@id":"https://liteonline.com/these-are-the-10-most-hated-roundabouts-in-the-treasure-valley/"},"description":"Did you know Boise didn't have a roundabout until 2006? It's taken us 15 years to make up for lost time.","@id":"https://liteonline.com/these-are-the-10-most-hated-roundabouts-in-the-treasure-valley/#article","image":"//townsquare.media/site/660/files/2021/07/attachment-Parkcenter.jpg","author":{"@type":"Person","name":"Michelle Heart","sameAs":"https://liteonline.com/author/michelleheart"},"keywords":["worst roundabouts in boise","new roundabouts in boise","where did that roundabout come from","where was idaho's first roundabout?","local news"],"datePublished":"2021-07-16T17:22:35.000Z","dateCreated":"2021-07-16T17:22:35.000Z","dateModified":"2022-12-06T02:15:53.000Z","isPartOf":{"@id":"https://liteonline.com/#website"}}]}</script>
        </head>
        <body>
          <script>(function(w,d){
        const
          getCookie = window.TSM.fn.getCookie,
          setCookie = window.TSM.fn.setCookie,
          alephExpire = 365*2;
          dealWithAlephCount = () => {
            let
              alephCount = getCookie( "aleph-count" );
            if( !alephCount ){
              setCookie( "aleph-count", 1, alephExpire );
            }else{
              setCookie( "aleph-count", parseInt( alephCount )+1 );
            }
          };
        let
          aleph = getCookie( "aleph" );
        if( aleph ){
          w.aleph = aleph;
          dealWithAlephCount();
        }else{
          w.addEventListener("message", (e) => {
            //console.log(e);
            if( e.data && e.data.aleph ){
              //console.log( "e.data.aleph", e.data.aleph );
              window.aleph = e.data.aleph;
              window.cQ = window.cQ || [];
              window.cQ.push(()=>{
                window.globalActionCreators && window.globalActionCreators.addAleph && window.globalActionCreators.addAleph( window.aleph )
              });
              setCookie( "aleph", e.data.aleph, alephExpire );
              dealWithAlephCount();
            }
          });
          let
            ifr = d.createElement( "iframe" );
          ifr.id = "aleph-iframe";
          ifr.title = "aleph";
          ifr.src = "https://cdn.production.townsquareblogs.com/aleph/";
          ifr.frameborder = "0";
          ifr.style = "display:none;"
          ifr.addEventListener("load", ()=>{
            ifr.contentWindow.postMessage({action: "getAleph"}, "https://cdn.production.townsquareblogs.com");
          });
          d.body.appendChild( ifr );
        }
      })(window, document);</script>
          <div id="fb-root"></div>
          <div id="app">
          <div><header id="site-menu-wrapper" class="leaderboard-style-default" aria-label="site header"><div id="skip-to-main"><a href="#main-content">Skip to main content</a><a href="#site-footer">Skip to site footer</a></div><div class="site-menu-drawer"><ul class="promo-links" aria-label="promoted links"><li><span>Trending:</span></li><li><a href="/santa-paws-voting-2022/">Santa Paws - Vote Now</a></li><li><a href="/christmas-wish-nominations-2022/">Christmas Wish Nominations</a></li><li><a href="/trans-siberian-orchestra-san-antonio/">TSO in San Antonio</a></li><li><a href="/tags/christmas-2022">Christmas 2022</a></li><li><a href="/feed-your-office-with-lite-fms-doughnut-dash-2/">Doughnut Dash</a></li><li><a href="/the-new-107-9-lite-fm-app-is-here-download-it-now-to-win/">LITE App</a></li><li><a href="/tags/boise-luxury-homes">Boise Luxury Homes</a></li><li><a href="/tags/road-trip-worthy/">Idaho Road Trip Planner</a></li></ul></div><div id="site-menu-bg"></div><div class="logo-next-to-logo-container"><a class="logo" itemProp="logo url" href="/" data-source="logo"><img src="//townsquare.media/site/660/files/2018/08/liteonline-logo-v21.png" alt="107.9 LITE FM"/></a><div class="next-to-logo"><div class="non-menu-content"><div class="admin-bar-wrap"></div><div class="tsm-ad tsm-ad-728" aria-label="advertisement"><div id="tsm-ad-728a"><!-- dynamic ad --></div></div></div><nav id="site-menu" class="hide-overflow" aria-label="primary navigation"><div class="wrapper"><span class="icon-menu"></span><div class="showticker-container" id="show-ticker"><div class="slider showticker-items"><div class="sizer"></div><div class="mover fade"><div id="promotion-22" class="stationtagline-container showticker-item"><div class="content"><a class="info" href="#">THE BEST VARIETY OF THE 80s, 90s, AND TODAY</a></div></div></div></div></div><ul class="links"><li class="hassub"><a href="/" data-source="nav">Home</a></li><li class="hassub"><a href="/djs" data-source="nav">DJs</a><ul class="links submenu"><li class="hassub"><a href="/djs" data-source="nav">All DJs</a></li><li class="hassub"><a href="/shows" data-source="nav">Schedule</a></li><li class="hassub"><a href="/author/michelleheart" data-source="nav">Michelle Heart</a></li><li class="hassub"><a href="/author/chrispickett/" data-source="nav">Marco</a></li><li class="hassub"><a href="/author/austinjen" data-source="nav">Jen Austin</a></li><li class="hassub"><a href="/author/bdelilah/" data-source="nav">Delilah</a></li><li class="hassub"><a href="/author/chris" data-source="nav">Chris</a></li></ul></li><li class="hassub"><a href="/listen-live" data-source="nav">Listen</a><ul class="links submenu"><li class="hassub"><a href="/listen-live" data-source="nav">Listen Live</a></li><li class="hassub"><a href="/alexa" data-source="nav">Alexa</a></li><li class="hassub"><a href="/googlehome" data-source="nav">Google Home</a></li><li class="hassub"><a href="/playlist" data-source="nav">Recently Played</a></li></ul></li><li class="hassub"><a href="/app" data-source="nav">App</a><ul class="links submenu"><li class="hassub"><a href="/download/ios" data-source="nav">Download iOS</a></li><li class="hassub"><a href="/download/android" data-source="nav">Download Android</a></li></ul></li><li class="hassub"><a href="/contests" data-source="nav">Win Stuff</a><ul class="links submenu"><li class="hassub"><a href="/registration" data-source="nav">Sign Up</a></li><li class="hassub"><a href="/contest-rules/" data-source="nav">Rules</a></li><li class="hassub"><a href="/help" data-source="nav">Contest Support</a></li></ul></li><li class="hassub"><a href="/help" data-source="nav">Contact</a><ul class="links submenu"><li class="hassub"><a href="/help" data-source="nav">Help &amp; Contact Info</a></li><li class="hassub"><a href="/feedback" data-source="nav">Send Feedback</a></li><li class="hassub"><a href="/advertise" data-source="nav">Advertise</a></li></ul></li><li class="hidden-menu hassub hide"><div class="more-icon link" aria-hidden="true">More</div><ul class="links submenu"><li class="hassub hide"><a href="/" data-source="nav">Home</a></li><li class="hassub hide"><a href="/djs" data-source="nav">DJs</a><ul class="links submenu"><li class="hassub"><a href="/djs" data-source="nav">All DJs</a></li><li class="hassub"><a href="/shows" data-source="nav">Schedule</a></li><li class="hassub"><a href="/author/michelleheart" data-source="nav">Michelle Heart</a></li><li class="hassub"><a href="/author/chrispickett/" data-source="nav">Marco</a></li><li class="hassub"><a href="/author/austinjen" data-source="nav">Jen Austin</a></li><li class="hassub"><a href="/author/bdelilah/" data-source="nav">Delilah</a></li><li class="hassub"><a href="/author/chris" data-source="nav">Chris</a></li></ul></li><li class="hassub hide"><a href="/listen-live" data-source="nav">Listen</a><ul class="links submenu"><li class="hassub"><a href="/listen-live" data-source="nav">Listen Live</a></li><li class="hassub"><a href="/alexa" data-source="nav">Alexa</a></li><li class="hassub"><a href="/googlehome" data-source="nav">Google Home</a></li><li class="hassub"><a href="/playlist" data-source="nav">Recently Played</a></li></ul></li><li class="hassub hide"><a href="/app" data-source="nav">App</a><ul class="links submenu"><li class="hassub"><a href="/download/ios" data-source="nav">Download iOS</a></li><li class="hassub"><a href="/download/android" data-source="nav">Download Android</a></li></ul></li><li class="hassub hide"><a href="/contests" data-source="nav">Win Stuff</a><ul class="links submenu"><li class="hassub"><a href="/registration" data-source="nav">Sign Up</a></li><li class="hassub"><a href="/contest-rules/" data-source="nav">Rules</a></li><li class="hassub"><a href="/help" data-source="nav">Contest Support</a></li></ul></li><li class="hassub hide"><a href="/help" data-source="nav">Contact</a><ul class="links submenu"><li class="hassub"><a href="/help" data-source="nav">Help &amp; Contact Info</a></li><li class="hassub"><a href="/feedback" data-source="nav">Send Feedback</a></li><li class="hassub"><a href="/advertise" data-source="nav">Advertise</a></li></ul></li></ul></li></ul><div class="site-menu-right"><a class="listen-live-cto cto" style="min-width:300px"></a><ul class="social-links"><li class="social"><a class="share-link youtube" href="https://youtube.com/user/1079litefm" target="_blank" rel="noopener noreferrer" data-social="youtube"><span class="visually-hidden">Visit us on Youtube</span></a></li><li class="social"><a class="share-link facebook" href="https://www.facebook.com/1079LiteBoise" target="_blank" rel="noopener noreferrer" data-social="facebook"><span class="visually-hidden">Visit us on Facebook</span></a></li><li class="social"><a class="share-link twitter" href="https://twitter.com/1079litefm" target="_blank" rel="noopener noreferrer" data-social="twitter"><span class="visually-hidden">Visit us on Twitter</span></a></li><li><ul class="social-subscriptions"><li class="sub-instagram "><a href="https://www.instagram.com/1079litefm" target="_blank" rel="noopener noreferrer">INSTAGRAM</a></li><li class="share_link_small youtube sub-youtube"></li><li class="sub-facebook"></li><li class="sub-twitter"></li></ul></li></ul><div id="search-form" class=""><div class="form-wrap"></div><div class="icon-base icon-search"></div></div></div><div class="site-screen select-none"></div></div></nav></div></div></header><div id="container" class=""><div id="top-not-ads" class=""><div id="tsm-ad-1x1-container"><div class="tsm-ad tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-oop"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-oop2"><!-- dynamic ad --></div></div></div></div><div class="tsm-ad tsm-ad-nav-970" aria-label="advertisement"><div id="tsm-ad-970a"><!-- dynamic ad --></div></div><div class="container-inner"><div class="site-content clearfix"><main id="main-content" class="main-content" tabindex="-1"><div class="wrapper post-wrapper"><div class="internal-header outgrow " style="max-height:0px"></div><div class="post clearfix"><div class="entry"><article id="post-162978" data-location="/these-are-the-10-most-hated-roundabouts-in-the-treasure-valley/" data-index="0" class=""><div class="page-header"><div class="content-header show-ui front" id="content-header-162978"><div class="content-header-header"><div class="react-parallax"><figure class="frameme temp-ssr" alt="These Are the 10 Most Hated Roundabouts in the Treasure Valley"><img src="https://townsquare.media/site/660/files/2021/07/attachment-Parkcenter.jpg?w=980&amp;q=75" alt="These Are the 10 Most Hated Roundabouts in the Treasure Valley"/></figure></div><div class="header"><section class="title "><h1 class="">These Are the 10 Most Hated Roundabouts in the Treasure Valley</h1></section><div class="byline"><div class="author-image"><div class="icon-user" aria-hidden="true"></div><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/660/files/2021/10/attachment-Michelle_Headshot.jpg" href="//liteonline.com/author/michelleheart/" rel="author"><figcaption class="visually-hidden">Michelle Heart</figcaption></a></figure></div><div class="not-author-image-stuff"><div class="not-author-image-stuff-row"><a class="author-name" href="//liteonline.com/author/michelleheart/" rel="author">Michelle Heart</a><time dateTime="2021-07-16 19:22:35 +0000">Published: July 16, 2021</time></div></div></div><figcaption>Image via Google Maps</figcaption></div></div></div></div><div class="content-wrap"><div class="social-share bignsexy"><div class="social-bar social-icons"><ul><li><a href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fliteonline.com%2Fthese-are-the-10-most-hated-roundabouts-in-the-treasure-valley%2F%3Ftrackback%3Dfbshare_mobile" title="Share on Facebook" target="_blank"><span class=" social-icon icon-facebook fb"><span class="share-title">Share on Facebook</span></span></a></li><li><a href="http://twitter.com/intent/tweet?text=These%20Are%20the%2010%20Most%20Hated%20Roundabouts%20in%20the%20Treasure%20Valley%20http%3A%2F%2Fliteonline.com%2Fthese-are-the-10-most-hated-roundabouts-in-the-treasure-valley%2F%3Ftrackback%3Dtwitter_mobile%20%401079litefm" title="Share on Twitter" target="_blank"><span class=" social-icon icon-twitter tw"><span class="share-title">Share on Twitter</span></span></a></li></ul></div></div><div class="content"><div class="pod-content"><p>You can tell us all day long that the biggest problems with roundabouts are the people that don&apos;t know how to use them. Well, excuse us Mr. Hot Shot.<span id="more-162978"></span></p><p>According to<a href="https://roundabout.kittelson.com/Roundabouts/Search?sortOrder=YearCompleted&amp;currentFilter=&amp;SearchString=&amp;Approaches=&amp;Driveways=&amp;YearCompleted=&amp;State=ID&amp;Country=&amp;ICDMin=&amp;ICDMax=&amp;format=&amp;"> this roundabouts database</a>, the Treasure Valley didn&apos;t have any roundabouts until 2006. The first ones in Ada County went in at South Touchmark Way and Louise Drive and South Touchmark Way and South Worth Way in Meridian. The first roundabout in Canyon County opened at Amity and Happy Valley the same year.</p><div class="in-article-oop-container"><div class="tsm-ad tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-in-article-oop-1"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-1x1 tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-in-article-pixel-1"><!-- dynamic ad --></div></div></div><p>That means, there&apos;s a pretty decent amount of Boise natives over the age of 33 that didn&apos;t &quot;spend their whole lives&quot; driving through roundabouts. Sure, we&apos;ve had 15 years to close that learning gap, but doesn&apos;t it seem like there&apos;s a new roundabout popping up out of nowhere every other week?</p><div class="branded-app-shortcode-inarticle"><div class="logo-wrap"><img src="https://townsquare.media/wp-content/uploads/2019/05/KXLTFM.png?w=100"/></div><div class="phone-input"><div><div><div class="description-wrap desc-short"><div class="description">Get our free mobile app</div></div></div><div class="bap-enter-number"><input type="text" placeholder="Enter mobile number" maxLength="10"/></div></div></div><div style="clear:both"></div></div><p>According to the&#xA0;<a href="https://wsdot.wa.gov/Safety/roundabouts/benefits.htm">Insurance Institute for Highway Safety</a>&#xA0;roundabouts cut down on accidents by quite a bit. Overall, they help reduce collisions by 37%. They also reduce injury collisions 75% and fatal collisions by 90%. It&apos;s because people aren&apos;t rushing to beat a light, traveling too fast or misjudging who got to a stop signal first when there&apos;s a roundabout involved.</p><p style="text-align:center"><em><a href="https://liteonline.com/listen-live">Listen to&#xA0;</a>Michelle Heart mornings on 107.9 LITE-FM and&#xA0;<a href="https://liteonline.com/app">download</a>&#xA0;the FREE LITE-FM app.</em></p><p>So, in the long run as the Treasure Valley continues to grow, the roundabouts will probably help improve the flow of traffic but for now, most of can agree that some of these are just obnoxious and annoying.</p><div class="photogallery-wrapper"><h2 class="photogallery-title">These Are the 10 Most Hated Roundabouts in the Boise Area</h2></div><div class="photogallery-wrapper"><h2 class="photogallery-title">10 Things Guaranteed to Give Boise Drivers Road Rage </h2></div><div class="photogallery-wrapper"><h2 class="photogallery-title">28 Google Street View Images That Show Just How Much Boise Has Changed</h2></div></div></div><div class="content-footer"><div class="tags-lines"><div class="wrapper tags"><span>Filed Under<!-- -->: </span><span><a href="//liteonline.com/tags/construction/">construction</a></span><span>, <a href="//liteonline.com/tags/growth/">growth</a></span><span>, <a href="//liteonline.com/tags/newsletter/">newsletter</a></span><span>, <a href="//liteonline.com/tags/traffic/">Traffic</a></span></div><div class="wrapper categories"><span>Categories<!-- -->: </span><span><a href="//liteonline.com/category/local-news/">Local News</a></span></div></div><div class="comments-wrapper"><div class="comments"><div><i>Comments</i><span class="icon-triangle-down" aria-hidden="true"></span></div><div class="cto">Leave A Comment</div></div></div></div></div></article><div class="tsm-ad tsm-ad-728 tsm-ad-in-between-article" aria-label="advertisement"><div id="tsm-ad-728c-1"><!-- dynamic ad --></div></div><section id="ts_blogroll-afterpost" class="blogroll row-standard-3x ts_blogroll outgrow"><header class="header-band"><h2 class="">More From 107.9 LITE FM</h2></header><div class="blogroll-inner clearfix"><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/660/files/2022/12/attachment-317858920_482752357294881_3457782188058257119_n.jpg" href="/christmas-wish-2022-wish-6/" rel="" data-source="blogroll"><figcaption class="visually-hidden">LITE-FM Brings Amazing Christmas Surprise to Caldwell Mom Recovering From Scary Accident</figcaption></a></figure><div class="content"><a href="/christmas-wish-2022-wish-6/" class="title" data-source="blogroll">LITE-FM Brings Amazing Christmas Surprise to Caldwell Mom Recovering From Scary Accident</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/660/files/2022/12/attachment-412-w-washington_01.jpg" href="/small-homes-december-22/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Look Inside 10 Amazingly Small Homes for Sale in the Boise Area</figcaption></a></figure><div class="content"><a href="/small-homes-december-22/" class="title" data-source="blogroll">Look Inside 10 Amazingly Small Homes for Sale in the Boise Area</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/660/files/2022/11/attachment-noelle-BK4rszchcE4-unsplash.jpg" href="/santa-paws-voting-2022/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Vote Now for 107.9 LITE-FM&#8217;s Santa Paws 2022 &#8211; Round 1</figcaption></a></figure><div class="content"><a href="/santa-paws-voting-2022/" class="title" data-source="blogroll">Vote Now for 107.9 LITE-FM&#8217;s Santa Paws 2022 &#8211; Round 1</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/660/files/2022/12/attachment-attachment-evie-fjord-f11kuveftg4-unsplash.jpeg" href="/white-christmas-2022/" rel="" data-source="blogroll"><figcaption class="visually-hidden">What Are The Chances of Boise Having a White Christmas in 2022?</figcaption></a></figure><div class="content"><a href="/white-christmas-2022/" class="title" data-source="blogroll">What Are The Chances of Boise Having a White Christmas in 2022?</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/660/files/2021/12/attachment-christmas_wish_slider1.jpg" href="/christmas-wish-2022-wish-5/" rel="" data-source="blogroll"><figcaption class="visually-hidden">LITE-FM Brings Much Needed Christmas Joy to Payette Mom With Chronic Illness</figcaption></a></figure><div class="content"><a href="/christmas-wish-2022-wish-5/" class="title" data-source="blogroll">LITE-FM Brings Much Needed Christmas Joy to Payette Mom With Chronic Illness</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/660/files/2022/11/attachment-attachment-GettyImages-1231719582-1.jpeg" href="/warming-up-car-2022/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Is It Illegal to Warm Your Car Up in Idaho If You&#8217;re Not Inside Of It?</figcaption></a></figure><div class="content"><a href="/warming-up-car-2022/" class="title" data-source="blogroll">Is It Illegal to Warm Your Car Up in Idaho If You&#8217;re Not Inside Of It?</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/660/files/2022/10/attachment-RS33420_ThinkstockPhotos-499518664-scr.jpg" href="/horn-honking-illegal-2022/" rel="" data-source="blogroll"><figcaption class="visually-hidden">There is Only One Reason You Can Legally Honk Your Horn in Idaho</figcaption></a></figure><div class="content"><a href="/horn-honking-illegal-2022/" class="title" data-source="blogroll">There is Only One Reason You Can Legally Honk Your Horn in Idaho</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/660/files/2022/10/attachment-attachment-15.jpg" href="/34-crazy-photos-show-how-much-the-boise-mall-area-has-changed-in-15-years/" rel="" data-source="blogroll"><figcaption class="visually-hidden">34 Crazy Photos Show How Much the Boise Mall Area Has Changed in 15 Years</figcaption></a></figure><div class="content"><a href="/34-crazy-photos-show-how-much-the-boise-mall-area-has-changed-in-15-years/" class="title" data-source="blogroll">34 Crazy Photos Show How Much the Boise Mall Area Has Changed in 15 Years</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/659/files/2022/08/attachment-Photo-by-Alex-Gudino-on-Unsplash-Canva.jpg" href="/16-ridiculous-idaho-license-plates/" rel="" data-source="blogroll"><figcaption class="visually-hidden">How Are These 16 Idaho License Plates Actually Taken?</figcaption></a></figure><div class="content"><a href="/16-ridiculous-idaho-license-plates/" class="title" data-source="blogroll">How Are These 16 Idaho License Plates Actually Taken?</a></div></article></div></section></div></div></div></main><aside class="main-aside" aria-label="sidebar"></aside></div><section class="site-footer"><footer id="site-footer" tabindex="-1"><div class="links clearfix"><div class="logo"></div><div class="details"><h2>Information</h2><ul><li class=""><a href="/eeo/" aria-label="EEO">EEO</a></li><li class=""><a href="/advertising-and-marketing-for-business/boise-id/" aria-label="Marketing and Advertising Solutions">Marketing and Advertising Solutions</a></li><li class="next-one-merge"><a href="https://publicfiles.fcc.gov/fm-profile/KXLT-FM" aria-label="KXLTFM Public File">Public File</a></li><li class="last-one-merge"><a href="/kxlt-public-file/" aria-label="Persons with disabilities who need assistance with the KXLTFM / KXLT Public File">Need Assistance</a></li><li class=""><a href="/fcc-applications/" aria-label="FCC Applications">FCC Applications</a></li><li class=""><a href="/report-an-inaccuracy" aria-label="Report an Inaccuracy">Report an Inaccuracy</a></li><li class=""><a href="/terms/" aria-label="Terms">Terms</a></li><li class=""><a href="/contest-rules/" aria-label="Contest Rules">Contest Rules</a></li><li class=""><a href="/privacy/" aria-label="Privacy Policy">Privacy Policy</a></li><li class=""><a href="/digital-accessibility-statement/" aria-label="Accessibility Statement">Accessibility Statement</a></li><li class=""><a href="/privacy/preferences/" aria-label="Exercise My Data Rights">Exercise My Data Rights</a></li><li class=""><a href="/help/" aria-label="Contact">Contact</a></li><li class=""><a href="/boise-featured-business-listings/" aria-label="Boise Business Listings">Boise Business Listings</a></li></ul></div><div class="social-links"><h2>Follow Us</h2><ul><li class="social"><a class="share_link youtube" href="https://www.youtube.com/user/1079litefm" target="_blank" rel="noopener noreferrer" data-social="youtube"><span class="visually-hidden">Visit us on Youtube</span></a></li><li class="social"><a class="share_link facebook" href="https://www.facebook.com/1079LiteBoise" target="_blank" rel="noopener noreferrer" data-social="facebook"><span class="visually-hidden">Visit us on Facebook</span></a></li><li class="social"><a class="share_link twitter" href="https://twitter.com/1079litefm" target="_blank" rel="noopener noreferrer" data-social="twitter"><span class="visually-hidden">Visit us on Twitter</span></a></li></ul></div></div><div class="legal">2022<!-- --> <!-- -->107.9 LITE FM<a href="https://www.townsquaremedia.com">, Townsquare Media, Inc</a>. All rights reserved.</div></footer></section></div><section class="bottom-components"><div id="bottom-not-ads"><div class="tsm-ad tsm-ad-728" aria-label="advertisement"><div id="tsm-ad-728b"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-interstitial" aria-label="advertisement"><div id="tsm-ad-interstitial"><!-- dynamic ad --></div></div></div></section></div></div></div>
          <script style="display: none;">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</script>
          
          
          
          
          
          
          
          
          
          
          <script type="text/javascript">
      window._taboola = window._taboola || [];
      _taboola.push({flush: true});
    </script>
          <script>(function(d){
            var getFile = window.TSM.fn.getFile;
            try{
              let
                getDependencies = function(){
                  return new Promise(async function( res, rej ){
                    var dependencies = ["//townsquare.media/public/dist/desktop/main.bundle.7de44a93c6ab86b5f8800facee2078010e182b63.js?mver=102&gver=3"];
                    for(var i=0;i<dependencies.length;i++){
                      await getFile( dependencies[i] );
                    }
                    res({});
                  });
                },
                getInitialState = function(){
                  return fetch( [ location.pathname, location.search, ( location.search ? "&" : "?" ), "initialState=7de44a93c6ab86b5f8800facee2078010e182b63" ].join( "" ) )
                    .then( response => {
                      if( !response.ok ){
                        if( response.status === 404 ){
                          return response;
                        }
                        throw Error( response.statusText );
                      }
                      return response;
                    })
                    .then( response => response.json() )
                    .catch(( err )=>{
                      console.log( "Carbon - Error in Rest response", err );
                    });
                };
              let allTasks = [ getDependencies() ];Promise.all( allTasks )
                  .then(function(results){
                    window.initCarbon && window.initCarbon();
                  });
            }catch(e){console.error(e);}
          })(document);</script>
          
        </body>
      </html>