<!doctype html>
      <html class="single desktop layout-clean fixed-full-width" lang="en">
        <head>
          <title>Why Boise And Caldwell Want You To Run On Thanksgiving Morning</title>
          <meta http-equiv="Content-Type" content="text/html;charset=UTF-8"/><meta charset="UTF-8"/><meta name="instagram_profile" value="1079litefm"/><meta name="description" content="It&#x27;s incredible how many turkeys you&#x27;ll see running around Boise and Caldwell on Thursday morning."/><meta name="keywords" content="turkey day 5k boise, turkey day 5k caldwell, thanksgiving day idaho, ,local news"/><meta property="fb:app_id" content="151245606939829"/><meta property="fb:admins" content="100002025987268"/><meta property="fb:use_automatic_ad_placement" content="false"/><meta property="og:title" content="Why Boise And Caldwell Want You To Run On Thanksgiving Morning"/><meta property="og:description" content="It&#x27;s incredible how many turkeys you&#x27;ll see running around Boise and Caldwell on Thursday morning."/><meta property="og:url" content="https://liteonline.com/why-boise-and-caldwell-want-you-to-run-on-thanksgiving-morning/"/><meta property="og:site_name" content="107.9 LITE FM"/><meta property="og:type" content="article"/><meta property="og:image:width" content="1200"/><meta property="og:image:height" content="630"/><meta property="og:image" content="https://townsquare.media/site/658/files/2021/11/attachment-img_4933.JPG?w=1200&#x26;h=0&#x26;zc=1&#x26;s=0&#x26;a=t&#x26;q=89"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@1079litefm"/><meta name="sailthru.description" content="It&#x27;s incredible how many turkeys you&#x27;ll see running around Boise and Caldwell on Thursday morning."/><meta name="sailthru.date" content="2022-11-01 17:23:46"/><meta name="sailthru.title" content="Why Boise And Caldwell Want You To Run On Thanksgiving Morning"/><meta name="sailthru.tags" content="tsmsite-kxlt, tsmmarket-boise, tsmtype-local, newsletter, thanksgiving-day-idaho, turkey-day-5k-boise, turkey-day-5k-caldwell, local-news"/><meta name="sailthru.author" content="kevinmiller"/><meta name="sailthru.image.full" content="https://kidotalkradio.com/files/2021/11/attachment-img_4933.JPG"/><meta name="sailthru.image.thumb" content="https://kidotalkradio.com/files/2021/11/attachment-img_4933.JPG"/><meta name="robots" content="max-image-preview:large"/><meta property="fb:pages" content="138647476157057"/>
          <link rel="preload" href="/styles/desktop/base.css?ver=2730341c0d44b114044f211b0334540c1ec67ae6&mver=102&gver=3" as="style"/><link rel="preload" href="//townsquare.media/public/dist/desktop/main.bundle.2730341c0d44b114044f211b0334540c1ec67ae6.js?mver=102&gver=3" as="script"/><link rel="preconnect" href="https://btloader.com" crossorigin /><link rel="preconnect" href="https://action.dstillery.com" crossorigin /><link rel="preconnect" href="https://px.owneriq.net" crossorigin /><link rel="preconnect" href="https://cdn.taboola.com" crossorigin />
          <link id="design-fav" rel="shortcut icon" href="https://townsquare.media/site/660/files/2018/03/LiteFavilogo1.gif"/><link rel="profile" href="http://gmpg.org/xfn/11"/><link rel="prev" title="Idaho Has The Best Loaded Fries In The Country" href="https://liteonline.com/best-loaded-fries-in-the-country-2022/"/><link rel="canonical" href="https://kidotalkradio.com/why-boise-and-caldwell-want-you-to-run-on-thanksgiving-morning/"/><link rel="apple-touch-icon-precomposed" href="https://townsquare.media/wp-content/uploads/2019/05/KXLTFM.png?w=57&h=57"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://townsquare.media/wp-content/uploads/2019/05/KXLTFM.png?w=144&h=144"/><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://townsquare.media/wp-content/uploads/2019/05/KXLTFM.png?w=72&h=72"/>
          <!-- <link href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap" rel="stylesheet" type="text/css" /> -->
          <!-- connect to domain of font files -->
          <link rel="preconnect" href="https://fonts.googleapis.com" crossorigin/>
          <!-- optionally increase loading priority -->
          <link rel="preload" as="style" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap">
          <!-- async CSS -->
          <link rel="stylesheet" media="print" onload="this.onload=null;this.removeAttribute('media');" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap">
          <!-- no-JS fallback -->
          <noscript>
            <link rel="stylesheet" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap">
          </noscript>
          <link href="/styles/desktop/base.css?ver=2730341c0d44b114044f211b0334540c1ec67ae6&mver=102&gver=3" rel="stylesheet" type="text/css" />
          <script>window.TSM = window.TSM ||{}; window.TSM.fn = window.TSM.fn || {}; window.TSM.fn.isIe = function(n){var t,i;return(n=n||"",!n||n===null||typeof n=="undefined"||n&&!n.match)?!1:(t=n.match(/MSIEs([d.]+)/i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):(t=n.match(/Trident.*rv[ :]*(11)./i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):!1};
      window.TSM.fn.getFile=function(n,t={},i=document.body){return new Promise(function(r){var e=function(n){n.target.removeEventListener("load",e);r(n.target)},u=document.createElement("script"),f;u.addEventListener("load",e);u.src=n;for(f in t)u.setAttribute(f,t[f]);i.appendChild(u)})};
      window.TSM.fn.getCookie = window.TSM.fn.getCookie || function(n){var i="; "+document.cookie,t=i.split("; "+n+"=");if(t.length==2)return t.pop().split(";").shift()};
      window.TSM.fn.setCookie = window.TSM.fn.setCookie || function(n,t,i,r="/"){var f="",u;i&&(u=new Date,u.setTime(u.getTime()+i*864e5),f="; expires="+u.toUTCString());document.cookie=n+"="+(t||"")+f+"; path="+r};
    </script>
          <script>window.taskQ=[];</script>
          
        <script type="text/javascript">
          window.TSM = window.TSM || {q:[]};
          window.TSM.abgroup = "A";
          window.TSM.cadata = {"activeDomain":"liteonline.com","blogId":660,"method":"get_single","postId":189259,"crosspostBlogId":"658","crosspostPostId":"161306","postType":"post","postDateGmt":"2022-11-01 23:23:46.000+0000"};
          window.TSM.startload = new Date().getTime();
        </script>
          <script>
    (function () {
      function getCookie(name) {
        var value = "; " + document.cookie;
        var parts = value.split("; " + name + "=");
        if (parts.length == 2) return parts.pop().split(";").shift();
      }
      function updateCookie(name, value, expireDays) {
        let d = new Date();
        d.setTime(d.getTime() + (60*60*24*expireDays*1000));
        var expires = "expires="+ d.toUTCString();
        document.cookie = name + "=" + value + ";" + expires + ";path=/";
      }
      window.TSM = window.TSM || {};
      if (window.TSM.abgroup) {
        updateCookie("abgroup", window.TSM.abgroup, 90);
      }

      var xhr = new XMLHttpRequest();
      xhr.open("POST", "/rest/high/api/cogitoergosum", true);
      var cogitoergosum = getCookie("cogitoergosum");
      var abgroup = getCookie("abgroup");
      if (cogitoergosum) {
        window.TSM.cogitoergosum = JSON.parse( atob( decodeURIComponent( cogitoergosum ) ) );
      }
      xhr.onreadystatechange = function() {//Call a function when the state changes.
        if(xhr.readyState == XMLHttpRequest.DONE && xhr.status == 200) {
          if (xhr.response) {
            var result = JSON.parse(xhr.response);
            if (result && result.result) {
              if (result.result.cookie) {
                window.TSM.cogitoergosum = JSON.parse( atob( result.result.cookie ) );
              }
              if (result.result.credentials) {
                window.TSM.credentials = JSON.parse( atob( result.result.credentials ) );
              }
              // console.log("cogitoergosum xhr", window.TSM.cogitoergosum);
            }
          }
        }
      };
      xhr.setRequestHeader("Content-type", "application/json");
      var cadata = window.TSM.cadata || {};
      cadata.experimentGroup = window.TSM.abgroup;
      cadata.viewType = "standard";
      cadata.timespent = new Date().getTime() - window.TSM.startload;
      var referrer = document.referrer;
      var sendData = {
        type: "pageview",
        referrer: referrer,
        url: document.location.href,
        queryParam: document.location.queryParam,
        pageData: cadata,
        scrollPageIndex: 0
      };
      xhr.send(JSON.stringify(sendData));
    }());
  </script>
          <script>(function(w,d){
        const
          getCookie = w.TSM.fn.getCookie;
        let
          aleph = getCookie( "aleph" );
        if( aleph ){
          w.aleph = aleph;
        }
      })(window, document);</script>
          <script>
            (function(w){
              w.ga=w.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
              var gaInitData = {"hitType":"pageview","dimension1":"kevinmiller","dimension2":"local-news","dimension3":"newsletter,thanksgiving-day-idaho,turkey-day-5k-boise,turkey-day-5k-caldwell,kidotalkradio-xpost","dimension4":"post","dimension5":"Tue Nov 01 2022","dimension6":"17:23","dimension7":"standard","dimension8":"433","dimension9":"A","dimension10":"yes","dimension12":"","dimension13":"","dimension14":"","dimension15":"","dimension16":""};
gaInitData.dimension13=function(){let refData=sessionStorage.getItem("itemRef"),str=[];return refData&&(refData=JSON.parse(refData),refData.title&&(str.push(refData.title),str.push(refData.source||"NA")),sessionStorage.removeItem("itemRef"),window.opener&&window.opener.sessionStorage&&window.opener.sessionStorage.removeItem("itemRef")),str.join(" -|- ");}();
gaInitData.dimension15=window.aleph || "";
gaInitData.dimension16=navigator.userAgent || "";
window.globalDimensionData = {"dimension1":"kevinmiller","dimension2":"local-news","dimension3":"newsletter,thanksgiving-day-idaho,turkey-day-5k-boise,turkey-day-5k-caldwell,kidotalkradio-xpost","dimension4":"post","dimension5":"Tue Nov 01 2022","dimension6":"17:23","dimension7":"standard","dimension8":"433","dimension9":"A","dimension10":"yes","dimension12":"","dimension13":"","dimension14":"","dimension15":"","dimension16":""};
window.globalDimensionData.dimension15=window.aleph || "";
ga( "create", {
          trackingId:"UA-45254601-8",
          name: "primary",
          allowAnchor: false
        });
        
        ga( "primary.require", "displayfeatures" );
        ga( "primary.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "primary.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "primary" ] = {gaid:"UA-45254601-8"};
ga( "create", {
          trackingId:"UA-19109753-1",
          name: "UA191097531",
          allowAnchor: false
        });
        
        ga( "UA191097531.require", "displayfeatures" );
        ga( "UA191097531.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA191097531.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA191097531" ] = {gaid:"UA-19109753-1"};
ga( "create", {
          trackingId:"UA-45254601-2",
          name: "UA452546012",
          allowAnchor: false
        });
        
        ga( "UA452546012.require", "displayfeatures" );
        ga( "UA452546012.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA452546012.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA452546012" ] = {gaid:"UA-45254601-2"};
ga( "create", {
          trackingId:"UA-28825804-1",
          name: "UA288258041",
          allowAnchor: false
        });
        
        ga( "UA288258041.require", "displayfeatures" );
        ga( "UA288258041.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA288258041.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA288258041" ] = {gaid:"UA-28825804-1"};
ga( "create", {
          trackingId:"UA-45260060-5",
          name: "UA452600605",
          allowAnchor: false
        });
        
        ga( "UA452600605.require", "displayfeatures" );
        ga( "UA452600605.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA452600605.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA452600605" ] = {gaid:"UA-45260060-5"};
ga( "create", {
          trackingId:"UA-180756957-2",
          name: "UA1807569572",
          allowAnchor: false
        });
        
        ga( "UA1807569572.require", "displayfeatures" );
        ga( "UA1807569572.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA1807569572.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA1807569572" ] = {gaid:"UA-180756957-2"};
            })(window);
          </script>
          <script async defer src="https://www.google-analytics.com/analytics.js"></script>
          <script async defer src="//townsquare.media/public/resources/js/autotrack.carbon.js"></script>
          <script>(function(w){
      w.dataLayer = [{"title":"Why Boise And Caldwell Want You To Run On Thanksgiving Morning","callsign":"KXLTFM","market":"Boise","sitetype":"Local","siteClassification":"Local","state":"ID","genre":"pop,classic-hits","pageType":"post","tags":"newsletter,thanksgiving-day-idaho,turkey-day-5k-boise,turkey-day-5k-caldwell,kidotalkradio-xpost","categories":"local-news","mediaType":"gallery","aleph":"","userAgent":"","GaIds":"","GaPrimaryId":"","GaMarketRollupId":"","GaCompanyRollupId":"","GaRegionRollupId":"","GaStationRollupId":""}];
      w.dataLayer[0].referer = document.referrer;w.dataLayer[0].curatedReferer = document.referrer.replace( /https?:\/\//, "" );w.dataLayer[0].dayOfWeek = function(n){return n.toLocaleString("en-US",{weekday:"long"})}(new Date);w.dataLayer[0].periodOfDay = function(n,t,i){t=n.getHours(),i=n.getMinutes(),i<10&&(i="0"+i);var r=parseInt(t+""+i);return r>=0&&r<600?"Overnight":r>=600&&r<1e3?"Morning Drive":r>=1e3&&r<1500?"Midday":r>=1500&&r<1900?"Afternoon Drive":r>=1900&&r<2400?"Evening":void 0}(new Date);
    })(window);</script>
          <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start": new Date().getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!="dataLayer"?"&l="+l:"";j.async=true;j.src= "https://www.googletagmanager.com/gtm.js?id="+i+dl;f.parentNode.insertBefore(j,f); })(window,document,"script","dataLayer","GTM-K346HJZ");</script>
          
        <script>
        window.taskQ=window.taskQ||[];window.taskQ.push(function(){
          (function(w,dl){
            var
              isUS = RegExp( "us-region-source=CA" ).exec( document.cookie );
            const
              addOipScript = function(){
                if( dl && dl[0] ){
                  dl = dl[0];
                  w._oiqq = w._oiqq || [];
                  var keywordMeta = document.querySelector( "meta[name='keywords']");
                  _oiqq.push(["oiq_addPageBrand", "title:" + dl.title]);
                  _oiqq.push(["oiq_addPageBrand", "domain:" + location.hostname]);
                  _oiqq.push(["oiq_addPageBrand", "callsign:" + dl.callsign]);
                  _oiqq.push(["oiq_addPageCat", "url_path:" + location.pathname]);
                  _oiqq.push(["oiq_addPageCat", "meta_keywords:" + ( keywordMeta ? keywordMeta.content : "" ) ]);
                  _oiqq.push(["oiq_addPageCat", "title:" + dl.title]);
                  _oiqq.push(["oiq_addPageCat", "callsign:" + dl.callsign]);
                  _oiqq.push(["oiq_addPageCat", "market:" + dl.market]);
                  _oiqq.push(["oiq_addPageCat", "sitetype:" + dl.sitetype]);
                  _oiqq.push(["oiq_addPageCat", "state:" + dl.state]);
                  _oiqq.push(["oiq_addPageCat", "page_type:" + dl.pageType]);
                  _oiqq.push(["oiq_addPageCat", "media_type:" + dl.mediaType]);
                  _oiqq.push(["oiq_addPageCat", "day_of_week:" + dl.dayOfWeek]);
                  _oiqq.push(["oiq_addPageCat", "newsletter_submission:" + (dl.newsletterSubmission || "no")]);
                  _oiqq.push(["oiq_addPageCat", "period_of_day:" + dl.periodOfDay]);
                  _oiqq.push(["oiq_addPageCat", "curated_referer:" + dl.curatedReferer]);
                  _oiqq.push(["oiq_addPageCat", "genre:" + dl.genre]);
                  _oiqq.push(["oiq_addPageCat", "tags:" + dl.tags]);
                  _oiqq.push(["oiq_addPageCat", "categories:" + dl.categories]);
                  _oiqq.push(["oiq_doTag"]);
                  _oiqq.push(["oiq_addPageLifecycle", "ecv3"]);
                }
                var oiq = document.createElement("script"); oiq.type = "text/javascript"; oiq.async = true; oiq.defer = true;
                oiq.src = document.location.protocol + "//px.owneriq.net/stas/s/0frxgz.js";
                var s = document.getElementsByTagName("script")[0]; s.parentNode.insertBefore(oiq, s);
              },
              callback =  (tcData, success) => {
                if(success && tcData.eventStatus === 'tcloaded') {
                  if( !tcData.gdprApplies || ( tcData.gdprApplies && tcData.tcString ) ){
                    addOipScript();
                  }
                  __tcfapi('removeEventListener', 2, (success) => {}, tcData.listenerId );
                }
              };
            __tcfapi( "addEventListener", 2, callback );
          })(window, window.dataLayer);
        });
      </script>
        
        
        
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
      (function (d, t) {
        var g = d.createElement(t), s = d.getElementsByTagName(t)[0];
        g.type='text/javascript';
        g.async = true;
        g.defer = true;
        g.src = 'https://btloader.com/tag?o=5642230212591616&upapi=true';
        s.parentNode.insertBefore(g, s)
      }(document, 'script'));
    });</script>
        
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
        window.TSM.fn.getFile("https://action.dstillery.com/orbserv/nsjs?adv=cl1016361&ns=3141&nc=KXLTFM&ncv=24", {"async": "async", "defer": "defer"});
        window.TSM.fn.getFile("https://action.dstillery.com/orbserv/nsjs?adv=cl1016361&ns=3141&nc=all_tsm_sv&ncv=24", {"async": "async", "defer": "defer"});
      });</script>
        
        
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
      (function (d, t) {
        var g = d.createElement(t), s = d.getElementsByTagName(t)[0];
        g.type='text/javascript';
        g.async = true;
        g.defer = true;
        g.src = '//townsquare.media/public/resources/js/pubcid.min.js';
        s.parentNode.insertBefore(g, s)
      }(document, 'script'));
    });</script>
          
          
          <script>//gdpr 2 - tcfapi stub
      ;!function(){var e=function(){var e,t="__tcfapiLocator",a=[],n=window;for(;n;){try{if(n.frames[t]){e=n;break}}catch(e){}if(n===window.top)break;n=n.parent}e||(!function e(){var a=n.document,r=!!n.frames[t];if(!r)if(a.body){var i=a.createElement("iframe");i.style.cssText="display:none",i.name=t,a.body.appendChild(i)}else setTimeout(e,5);return!r}(),n.__tcfapi=function(){for(var e,t=arguments.length,n=new Array(t),r=0;r<t;r++)n[r]=arguments[r];if(!n.length)return a;if("setGdprApplies"===n[0])n.length>3&&2===parseInt(n[1],10)&&"boolean"==typeof n[3]&&(e=n[3],"function"==typeof n[2]&&n[2]("set",!0));else if("ping"===n[0]){var i={gdprApplies:e,cmpLoaded:!1,cmpStatus:"stub"};"function"==typeof n[2]&&n[2](i)}else a.push(n)},n.addEventListener("message",(function(e){var t="string"==typeof e.data,a={};try{a=t?JSON.parse(e.data):e.data}catch(e){}var n=a.__tcfapiCall;n&&window.__tcfapi(n.command,n.version,(function(a,r){var i={__tcfapiReturn:{returnValue:a,success:r,callId:n.callId}};t&&(i=JSON.stringify(i)),e.source.postMessage(i,"*")}),n.parameter)}),!1))};"undefined"!=typeof module?module.exports=e:e()}();</script><script>
      window.cmpFactory = function( varName ) {
        var
          listen = window.attachEvent || window.addEventListener,
          isDebug = RegExp( "debug=([^&]+)" ).exec( location.search );
        listen('message', function(event) {
          window[ varName ].receiveMessage && window[ varName ].receiveMessage(event);
        });

        var commandQueue = [];
        var cmp = function(command, parameter, callback) {
          if( command === "ping" ){
            callback({cmpLoaded: false}, true);
          }else{
            commandQueue.push({
              command: command,
              parameter: parameter,
              callback: callback
            });
          }
        };
        cmp.commandQueue = commandQueue;
        cmp.receiveMessage = function(event) {
          var data = event && event.data && event.data[ varName + "Call" ];
          if (data) {
            commandQueue.push({
              callId: data.callId,
              command: data.command,
              parameter: data.parameter,
              event: event
            });
          }
        };
        cmp.config = {};
        if( isDebug && isDebug[1] && isDebug[1] === "YES" ){
          cmp.config.logging = "debug";
        }
        return cmp;
      };
      window.__cmp = window.cmpFactory( "__cmp" );
      window.__uspapi = window.cmpFactory( "__uspapi" );
    </script><script>
      (function(w) {
        w.TSM.fn.getFile( "//townsquare.media/public/resources/js/cmp.bundle.js", {}, document.head );
        w.cnvr_launcher_options={lid:336};
        w.TSM.fn.getFile( "https://secure.cdn.fastclick.net/js/cnvr-launcher/latest/launcher-stub.min.js", {}, document.head );
      })(window);
    </script>
          <link rel="preconnect" href="https://doi3unldljdx6.cloudfront.net." crossorigin/><script type="text/javascript" src="//doi3unldljdx6.cloudfront.net./script.js" async></script><script async type="text/javascript" src="https://native.sharethrough.com/assets/sfp.js"></script><script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
        <script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        </script>
<script async src="//js-sec.indexww.com/ht/p/186854-113710634486999.js"></script>
<script>window.pbjs=window.pbjs||{};window.pbjs.que=window.pbjs.que||[];window.PREBID_TIMEOUT=2000;</script>
<script src="https://cdn.production.townsquareblogs.com/wp-content/uploads/static/prebid/carbon/pb.js?domain=liteonline.com&v=2730341c0d44b114044f211b0334540c1ec67ae6&mver=102&gver=3" ></script>

<script>(function(){!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
        var params={pubID:"3227",adServer:"googletag",params:{us_privacy: (RegExp( "usprivacy=([^;]+)" ).exec( document.cookie ) || [])[1] || "1---"}};apstag.init(params);})();</script>


<script>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</script>
          <script defer src="https://apis.google.com/js/platform.js"></script>
      <script>window.twttr = (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0],
        t = window.twttr || {};
      if (d.getElementById(id)) return t;
      js = d.createElement(s);
      js.id = id;
      js.src = "https://platform.twitter.com/widgets.js";
      fjs.parentNode.insertBefore(js, fjs);
      t._e = [];
      t.ready = function(f) {
        t._e.push(f);
      };
      return t;
    }(document, "script", "twitter-wjs"));
    (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id;
      js.src = "//connect.facebook.net/en_US/sdk.js";
      fjs.parentNode.insertBefore(js, fjs);
    }(document, "script", "facebook-jssdk"));</script>
    <script async defer src="//platform.instagram.com/en_US/embeds.js"></script>
    <script type="text/javascript" async defer src="//assets.pinterest.com/js/pinit.js"></script>
    <script>var ZERG = ZERG || {};ZERG.domain = "liteonline.com";ZERG.user = 751;</script>
          <script type="text/javascript">
      window._taboola = window._taboola || [];
        _taboola.push({article:"auto"});
        !function (e, f, u, i) {
          if (!document.getElementById(i)){
            e.async = 1;
            e.src = u;
            e.id = i;
            f.parentNode.insertBefore(e, f);
          }
        }(document.createElement("script"),
          document.getElementsByTagName("script")[0],
          "//cdn.taboola.com/libtrc/townsquaremediatsm-network/loader.js",
          "tb_loader_script");
        if(window.performance && typeof window.performance.mark == "function")
        {window.performance.mark("tbl_ic");}
    </script>
          <script type="application/ld+json">{"@context":"https://schema.org","@graph":[{"@context":"https://schema.org/","@type":"NewsMediaOrganization","@id":"https://liteonline.com/#organization","name":"107.9 LITE FM","logo":{"@type":"ImageObject","@id":"https://liteonline.com/#sitelogo","url":"//townsquare.media/site/660/files/2015/11/logo.png"},"sameAs":["https://liteonline.com/"]},{"@context":"http://schema.org/","@type":"Website","@id":"https://liteonline.com/#website","publisher":{"@id":"https://liteonline.com/#organization"},"name":"107.9 LITE FM","url":"https://liteonline.com/"},{"@context":"https://schema.org","@type":"article","headline":"Why Boise And Caldwell Want You To Run On Thanksgiving Morning","publisher":{"@id":"https://liteonline.com/#organization"},"url":"https://liteonline.com/why-boise-and-caldwell-want-you-to-run-on-thanksgiving-morning/","mainEntityOfPage":{"@type":"WebPage","@id":"https://kidotalkradio.com/why-boise-and-caldwell-want-you-to-run-on-thanksgiving-morning/"},"description":"It's incredible how many turkeys you'll see running around Boise and Caldwell on Thursday morning.","@id":"https://liteonline.com/why-boise-and-caldwell-want-you-to-run-on-thanksgiving-morning/#article","image":"//townsquare.media/site/658/files/2021/11/attachment-img_4933.JPG","author":{"@type":"Person","name":"Kevin Miller","sameAs":"https://kidotalkradio.com/author/kevinmiller"},"keywords":["turkey day 5k boise","turkey day 5k caldwell","thanksgiving day idaho","local news"],"datePublished":"2022-11-01T21:23:46.000Z","dateCreated":"2022-11-01T21:23:46.000Z","dateModified":"2022-11-01T21:23:46.000Z","isPartOf":{"@id":"https://liteonline.com/#website"}}]}</script>
        </head>
        <body>
          <script>(function(w,d){
        const
          getCookie = window.TSM.fn.getCookie,
          setCookie = window.TSM.fn.setCookie;
        let
          aleph = getCookie( "aleph" );
        if( aleph ){
          w.aleph = aleph;
        }else{
          w.addEventListener("message", (e) => {
            //console.log(e);
            if( e.data && e.data.aleph ){
              //console.log( "e.data.aleph", e.data.aleph );
              window.aleph = e.data.aleph;
              window.cQ = window.cQ || [];
              window.cQ.push(()=>{
                window.globalActionCreators && window.globalActionCreators.addAleph && window.globalActionCreators.addAleph( window.aleph )
              });
              setCookie( "aleph", e.data.aleph, 365*2 );
            }
          });
          let
            ifr = d.createElement( "iframe" );
          ifr.id = "aleph-iframe";
          ifr.title = "aleph";
          ifr.src = "https://cdn.production.townsquareblogs.com/aleph/";
          ifr.frameborder = "0";
          ifr.style = "display:none;"
          ifr.addEventListener("load", ()=>{
            ifr.contentWindow.postMessage({action: "getAleph"}, "https://cdn.production.townsquareblogs.com");
          });
          d.body.appendChild( ifr );
        }
      })(window, document);</script>
          <div id="fb-root"></div>
          <div id="app">
          <div><header id="site-menu-wrapper" class="leaderboard-style-default" aria-label="site header"><div id="skip-to-main"><a href="#main-content">Skip to main content</a><a href="#site-footer">Skip to site footer</a></div><div class="site-menu-drawer"><ul class="promo-links" aria-label="promoted links"><li><span>Trending:</span></li><li><a href="/bsb-and-me-in-nyc/">BSB and Me in NYC</a></li><li><a href="/christmas-wish-nominations-2022/">Christmas Wish Nominations</a></li><li><a href="/radio/christmas-player/popup/?wo=true">Christmas Music</a></li><li><a href="/feed-your-office-with-lite-fms-doughnut-dash-2/">Doughnut Dash</a></li><li><a href="/the-new-107-9-lite-fm-app-is-here-download-it-now-to-win/">LITE App</a></li><li><a href="/tags/boise-eats">Boise Eats</a></li><li><a href="/tags/boise-luxury-homes">Boise Luxury Homes</a></li><li><a href="/tags/road-trip-worthy/">Idaho Road Trip Planner</a></li></ul></div><div id="site-menu-bg"></div><div class="logo-next-to-logo-container"><a class="logo" itemProp="logo url" href="/" data-source="logo"><img src="//townsquare.media/site/660/files/2018/08/liteonline-logo-v21.png" alt="107.9 LITE FM"/></a><div class="next-to-logo"><div class="non-menu-content"><div class="admin-bar-wrap"></div><div class="tsm-ad tsm-ad-728" aria-label="advertisement"><div id="tsm-ad-728a"><!-- dynamic ad --></div></div></div><nav id="site-menu" class="hide-overflow" aria-label="primary navigation"><div class="wrapper"><span class="icon-menu"></span><div class="showticker-container" id="show-ticker"><div class="slider showticker-items"><div class="sizer"></div><div class="mover fade"><div id="promotion-22" class="stationtagline-container showticker-item"><div class="content"><a class="info" href="#">THE BEST VARIETY OF THE 80s, 90s, AND TODAY</a></div></div></div></div></div><ul class="links"><li class="hassub"><a href="/" data-source="nav">Home</a></li><li class="hassub"><a href="/djs" data-source="nav">DJs</a><ul class="links submenu"><li class="hassub"><a href="/djs" data-source="nav">All DJs</a></li><li class="hassub"><a href="/shows" data-source="nav">Schedule</a></li><li class="hassub"><a href="/author/michelleheart" data-source="nav">Michelle Heart</a></li><li class="hassub"><a href="/author/chrispickett/" data-source="nav">Marco</a></li><li class="hassub"><a href="/author/austinjen" data-source="nav">Jen Austin</a></li><li class="hassub"><a href="/author/bdelilah/" data-source="nav">Delilah</a></li><li class="hassub"><a href="/author/chris" data-source="nav">Chris</a></li></ul></li><li class="hassub"><a href="/listen-live" data-source="nav">Listen</a><ul class="links submenu"><li class="hassub"><a href="/listen-live" data-source="nav">Listen Live</a></li><li class="hassub"><a href="/alexa" data-source="nav">Alexa</a></li><li class="hassub"><a href="/googlehome" data-source="nav">Google Home</a></li><li class="hassub"><a href="/playlist" data-source="nav">Recently Played</a></li></ul></li><li class="hassub"><a href="/app" data-source="nav">App</a><ul class="links submenu"><li class="hassub"><a href="/download/ios" data-source="nav">Download iOS</a></li><li class="hassub"><a href="/download/android" data-source="nav">Download Android</a></li></ul></li><li class="hassub"><a href="/contests" data-source="nav">Win Stuff</a><ul class="links submenu"><li class="hassub"><a href="/registration" data-source="nav">Sign Up</a></li><li class="hassub"><a href="/contest-rules/" data-source="nav">Rules</a></li><li class="hassub"><a href="/help" data-source="nav">Contest Support</a></li></ul></li><li class="hassub"><a href="/help" data-source="nav">Contact</a><ul class="links submenu"><li class="hassub"><a href="/help" data-source="nav">Help &amp; Contact Info</a></li><li class="hassub"><a href="/feedback" data-source="nav">Send Feedback</a></li><li class="hassub"><a href="/advertise" data-source="nav">Advertise</a></li></ul></li><li class="hidden-menu hassub hide"><div class="more-icon link" aria-hidden="true">More</div><ul class="links submenu"><li class="hassub hide"><a href="/" data-source="nav">Home</a></li><li class="hassub hide"><a href="/djs" data-source="nav">DJs</a><ul class="links submenu"><li class="hassub"><a href="/djs" data-source="nav">All DJs</a></li><li class="hassub"><a href="/shows" data-source="nav">Schedule</a></li><li class="hassub"><a href="/author/michelleheart" data-source="nav">Michelle Heart</a></li><li class="hassub"><a href="/author/chrispickett/" data-source="nav">Marco</a></li><li class="hassub"><a href="/author/austinjen" data-source="nav">Jen Austin</a></li><li class="hassub"><a href="/author/bdelilah/" data-source="nav">Delilah</a></li><li class="hassub"><a href="/author/chris" data-source="nav">Chris</a></li></ul></li><li class="hassub hide"><a href="/listen-live" data-source="nav">Listen</a><ul class="links submenu"><li class="hassub"><a href="/listen-live" data-source="nav">Listen Live</a></li><li class="hassub"><a href="/alexa" data-source="nav">Alexa</a></li><li class="hassub"><a href="/googlehome" data-source="nav">Google Home</a></li><li class="hassub"><a href="/playlist" data-source="nav">Recently Played</a></li></ul></li><li class="hassub hide"><a href="/app" data-source="nav">App</a><ul class="links submenu"><li class="hassub"><a href="/download/ios" data-source="nav">Download iOS</a></li><li class="hassub"><a href="/download/android" data-source="nav">Download Android</a></li></ul></li><li class="hassub hide"><a href="/contests" data-source="nav">Win Stuff</a><ul class="links submenu"><li class="hassub"><a href="/registration" data-source="nav">Sign Up</a></li><li class="hassub"><a href="/contest-rules/" data-source="nav">Rules</a></li><li class="hassub"><a href="/help" data-source="nav">Contest Support</a></li></ul></li><li class="hassub hide"><a href="/help" data-source="nav">Contact</a><ul class="links submenu"><li class="hassub"><a href="/help" data-source="nav">Help &amp; Contact Info</a></li><li class="hassub"><a href="/feedback" data-source="nav">Send Feedback</a></li><li class="hassub"><a href="/advertise" data-source="nav">Advertise</a></li></ul></li></ul></li></ul><div class="site-menu-right"><a class="listen-live-cto cto" style="min-width:300px"></a><ul class="social-links"><li class="social"><a class="share-link youtube" href="https://youtube.com/user/1079litefm" target="_blank" rel="noopener noreferrer" data-social="youtube"><span class="visually-hidden">Visit us on Youtube</span></a></li><li class="social"><a class="share-link facebook" href="https://www.facebook.com/1079LiteBoise" target="_blank" rel="noopener noreferrer" data-social="facebook"><span class="visually-hidden">Visit us on Facebook</span></a></li><li class="social"><a class="share-link twitter" href="https://twitter.com/1079litefm" target="_blank" rel="noopener noreferrer" data-social="twitter"><span class="visually-hidden">Visit us on Twitter</span></a></li><li><ul class="social-subscriptions"><li class="sub-instagram "><a href="https://www.instagram.com/1079litefm" target="_blank" rel="noopener noreferrer">INSTAGRAM</a></li><li class="share_link_small youtube sub-youtube"></li><li class="sub-facebook"></li><li class="sub-twitter"></li></ul></li></ul><div id="search-form" class=""><div class="form-wrap"></div><div class="icon-base icon-search"></div></div></div><div class="site-screen select-none"></div></div></nav></div></div></header><div id="container" class=""><div id="top-not-ads" class=""><div id="tsm-ad-1x1-container"><div class="tsm-ad tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-oop"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-oop2"><!-- dynamic ad --></div></div></div></div><div class="tsm-ad tsm-ad-nav-970" aria-label="advertisement"><div id="tsm-ad-970a"><!-- dynamic ad --></div></div><div class="container-inner"><div class="site-content clearfix"><main id="main-content" class="main-content" tabindex="-1"><div class="wrapper post-wrapper"><div class="internal-header outgrow " style="max-height:0px"></div><div class="post clearfix"><div class="entry"><article id="post-189259" data-location="/why-boise-and-caldwell-want-you-to-run-on-thanksgiving-morning/" data-index="0" class=""><div class="page-header"><div class="content-header show-ui front" id="content-header-189259"><div class="content-header-header"><div class="react-parallax"><figure class="frameme temp-ssr" alt="Why Boise And Caldwell Want You To Run On Thanksgiving Morning"><img src="//kidotalkradio.com/files/2021/11/attachment-img_4933.JPG?w=980&amp;q=75" alt="Why Boise And Caldwell Want You To Run On Thanksgiving Morning"/></figure></div><div class="header"><section class="title "><h1 class="">Why Boise And Caldwell Want You To Run On Thanksgiving Morning</h1></section><div class="byline"><div class="author-image"><div class="icon-user" aria-hidden="true"></div><figure class="frameme"><a class="theframe" data-image="//kidotalkradio.com/files/2020/10/kevin-miller-2018.png" href="//liteonline.com/author/kevinmiller/" rel="author"><figcaption class="visually-hidden">Kevin Miller</figcaption></a></figure></div><div class="not-author-image-stuff"><div class="not-author-image-stuff-row"><a class="author-name" href="//liteonline.com/author/kevinmiller/" rel="author">Kevin Miller</a><time dateTime="2022-11-01 23:23:46 +0000">Published: November 1, 2022</time></div></div></div><figcaption>KEVIN MILLER</figcaption></div></div></div></div><div class="content-wrap"><div class="social-share bignsexy"><div class="social-bar social-icons"><ul><li><a href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fliteonline.com%2Fwhy-boise-and-caldwell-want-you-to-run-on-thanksgiving-morning%2F%3Ftrackback%3Dfbshare_mobile" title="Share on Facebook" target="_blank"><span class=" social-icon icon-facebook fb"><span class="share-title">Share on Facebook</span></span></a></li><li><a href="http://twitter.com/intent/tweet?text=Why%20Boise%20And%20Caldwell%20Want%20You%20To%20Run%20On%20Thanksgiving%20Morning%20http%3A%2F%2Fliteonline.com%2Fwhy-boise-and-caldwell-want-you-to-run-on-thanksgiving-morning%2F%3Ftrackback%3Dtwitter_mobile%20%401079litefm" title="Share on Twitter" target="_blank"><span class=" social-icon icon-twitter tw"><span class="share-title">Share on Twitter</span></span></a></li></ul></div></div><div class="content"><div class="pod-content"><p><span data-preserver-spaces="true">November is a time of Thanksgiving and turkey. If you&apos;ve ever wanted to make room for that Thanksgiving feast and have a good time, then it&apos;s time to join us for the Treasure Turkey Day 5K. </span></p><p><span id="more-189259"></span></p><p><span data-preserver-spaces="true">For twelve years, folks in Boise have gathered on Thanksgiving morning to run, walk, stroll, and waddle before enjoying a traditional Thanksgiving feast. Once again, there will be two locations for Turkey Day 5K, Boise and Caldwell. </span></p><div class="in-article-oop-container sharethrough-container"><div class="tsm-ad tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-in-article-oop-1"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-1x1 tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-in-article-pixel-1"><!-- dynamic ad --></div></div></div><div class="single-post-image "><figure class="img-tag has-sizer alignnone"><div class="frame-sizer" style="padding-top:66.66666666666667%"></div><div class="theframe" data-image="//kidotalkradio.com/files/2021/11/attachment-img_4927.JPG" rel=""><span class="visually-hidden">Idahoans Love America</span></div><figcaption>KEVIN MILLER</figcaption><div class="loadinganim showbox" id="0"><div class="loader" style="width:30px;height:30px"><svg class="circular" viewBox="25 25 50 50" style="width:30px;height:30px" focusable="false" role="img" aria-labelledby="loading-anim-title"><title id="loading-anim-title">loading...</title><circle class="path" cx="50" cy="50" r="20" fill="none" stroke-width="4" stroke-miterlimit="10"></circle></svg></div></div></figure><div></div></div><p><span data-preserver-spaces="true">The Turkey Day 5K is an early morning run celebrating community, health, and burning some calories. Idahoans have no problem showing their Turkey Day spirit by dressing up in creative costumes. It&apos;s incredible how many turkeys you&apos;ll see running around Boise and Caldwell on Thursday morning.</span></p><p><span data-preserver-spaces="true">However, the run is for two great local charities, the Boise Rescue Mission and the Idaho Special Olympics. If you&apos;d like to participate in the Boise run, use the link&#xA0;</span><a class="editor-rtfLink" href="https://verticalendurance.enmotive.com/events/register/2022-turkey-day-5k-boise" target="_blank"><span data-preserver-spaces="true">here</span></a><span data-preserver-spaces="true">&#xA0;and the Caldwell link&#xA0;</span><a class="editor-rtfLink" href="https://verticalendurance.enmotive.com/events/register/2022-turkey-day-5k-caldwell" target="_blank"><span data-preserver-spaces="true">here</span></a><span data-preserver-spaces="true">.&#xA0;</span><strong><span data-preserver-spaces="true">Before you click on those links, use the code</span></strong><span data-preserver-spaces="true">&#xA0;</span><strong><span data-preserver-spaces="true">TD5K22 or Millersmission for a discount on the entry fees.&#xA0;</span></strong></p><p><span data-preserver-spaces="true">So why not make a difference, have fun, and burn many calories on Thanksgiving Day in Boise and Caldwell? For more details, check out our website&#xA0;</span><a class="editor-rtfLink" href="https://turkeyday5kboise.com/" target="_blank"><span data-preserver-spaces="true">here</span></a><span data-preserver-spaces="true">. We look forward to seeing you on Thanksgiving morning.&#xA0;</span></p><p>Still need convincing? Checkout our photos from last year below.</p><div class="photogallery-wrapper"><h2 class="photogallery-title">Boise Turkey Day 5 K Photos </h2><div class="photogallery-description"><div>Thousands of Idahoans woke up early to run for a good cause.  The Turkey Day 5K benefits the Boise Rescue Mission and the Special Olympics of Idaho.</div></div></div><div class="photogallery-wrapper"><h2 class="photogallery-title">Pictures From Previous Turkey Day 5K Races in Boise</h2><div class="photogallery-description"><div>One local annual tradition that is great for getting your metabolize up so you can eat more Thanksgiving dinner but it is also a fun way to start a long weekend&nbsp;with friends, family and community.&nbsp;<a href="https://turkeyday5kboise.com/" target="_blank">Turkey Day 5K</a></div></div></div><div class="photogallery-wrapper"><h2 class="photogallery-title">The Best Movies To Watch With Your Family Over Thanksgiving on Netflix</h2><div class="photogallery-description"><div>Home for the holidays? Need something to watch? Here are our Turkey Day recommendations for the whole family.</div></div></div></div></div><div class="content-footer"><div><div class="feed_attribution_after clearfix"> Source: <a href="//kidotalkradio.com/why-boise-and-caldwell-want-you-to-run-on-thanksgiving-morning/" target="_blank">Why Boise And Caldwell Want You To Run On Thanksgiving Morning</a>
</div></div><div class="tags-lines"><div class="wrapper tags"><span>Filed Under<!-- -->: </span><span><a href="//liteonline.com/tags/newsletter/">newsletter</a></span><span>, <a href="//liteonline.com/tags/thanksgiving-day-idaho/">Thanksgiving Day Idaho</a></span><span>, <a href="//liteonline.com/tags/turkey-day-5k-boise/">turkey day 5k Boise</a></span><span>, <a href="//liteonline.com/tags/turkey-day-5k-caldwell/">turkey day 5k Caldwell</a></span></div><div class="wrapper categories"><span>Categories<!-- -->: </span><span><a href="//liteonline.com/category/local-news/">Local News</a></span></div></div><div class="comments-wrapper"><div class="comments"><div><i>Comments</i><span class="icon-triangle-down" aria-hidden="true"></span></div><div class="cto">Leave A Comment</div></div></div></div></div></article><div class="tsm-ad tsm-ad-728 tsm-ad-in-between-article" aria-label="advertisement"><div id="tsm-ad-728c-1"><!-- dynamic ad --></div></div><section id="ts_blogroll-afterpost" class="blogroll row-standard-3x ts_blogroll outgrow"><header class="header-band"><h2 class="">More From 107.9 LITE FM</h2></header><div class="blogroll-inner clearfix"><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/660/files/2022/11/attachment-Christmas-Lights.jpg" href="/cda-lights-cruise-2022/" rel="" data-source="blogroll"><figcaption class="visually-hidden">One of the Very Best Christmas Lights Displays in America is in Idaho</figcaption></a></figure><div class="content"><a href="/cda-lights-cruise-2022/" class="title" data-source="blogroll">One of the Very Best Christmas Lights Displays in America is in Idaho</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/660/files/2022/11/attachment-GettyImages-1235170298.jpg" href="/bowl-game-predictions-nov-1/" rel="" data-source="blogroll"><figcaption class="visually-hidden">5 Way Too Early Bowl Game Projections for Boise State Football</figcaption></a></figure><div class="content"><a href="/bowl-game-predictions-nov-1/" class="title" data-source="blogroll">5 Way Too Early Bowl Game Projections for Boise State Football</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/657/files/2022/11/attachment-alden-skeie-cBx1EygM3BM-unsplash.jpg" href="/why-families-are-falling-in-love-with-boise/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Why Families Are Falling In Love With Boise</figcaption></a></figure><div class="content"><a href="/why-families-are-falling-in-love-with-boise/" class="title" data-source="blogroll">Why Families Are Falling In Love With Boise</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/657/files/2022/11/attachment-freddy-g-6eAfaHjqThk-unsplash.jpg" href="/boise-restaurants-that-are-putting-out-the-best-calzones/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Boise Restaurants That Are Putting Out The Best Calzones</figcaption></a></figure><div class="content"><a href="/boise-restaurants-that-are-putting-out-the-best-calzones/" class="title" data-source="blogroll">Boise Restaurants That Are Putting Out The Best Calzones</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/737/files/2022/11/attachment-Screen-Shot-2022-11-01-at-9.23.44-AM1.jpg" href="/despite-high-prices-boise-sees-nations-largest-rent-decrease/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Despite High Prices, Boise Sees Nation&#8217;s Largest Rent Decrease</figcaption></a></figure><div class="content"><a href="/despite-high-prices-boise-sees-nations-largest-rent-decrease/" class="title" data-source="blogroll">Despite High Prices, Boise Sees Nation&#8217;s Largest Rent Decrease</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/657/files/2022/10/attachment-geoffrey-moffett-TFRezw7pQwI-unsplash.jpg" href="/top-10-most-recommended-movie-theaters-in-the-boise-area/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Top 10 Most Recommended Movie Theaters in the Boise Area</figcaption></a></figure><div class="content"><a href="/top-10-most-recommended-movie-theaters-in-the-boise-area/" class="title" data-source="blogroll">Top 10 Most Recommended Movie Theaters in the Boise Area</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/657/files/2022/10/attachment-ryan-fish-mBIVF4eC5og-unsplash.jpg" href="/one-of-the-best-cities-for-real-estate-investing-in-america-is-in-idaho/" rel="" data-source="blogroll"><figcaption class="visually-hidden">One of the Best Cities for Real Estate Investing in America is in Idaho</figcaption></a></figure><div class="content"><a href="/one-of-the-best-cities-for-real-estate-investing-in-america-is-in-idaho/" class="title" data-source="blogroll">One of the Best Cities for Real Estate Investing in America is in Idaho</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/660/files/2021/12/attachment-christmas_wish_slider1.jpg" href="/christmas-wish-nominations-2022/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Christmas Wish is Back to Help Neighbors in Need; Make Your Nominations Here</figcaption></a></figure><div class="content"><a href="/christmas-wish-nominations-2022/" class="title" data-source="blogroll">Christmas Wish is Back to Help Neighbors in Need; Make Your Nominations Here</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/660/files/2022/10/attachment-star-card1-e1667251192865.jpg" href="/star-card-2022/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Time is Running Out For Your Regular Idaho Driver&#8217;s License</figcaption></a></figure><div class="content"><a href="/star-card-2022/" class="title" data-source="blogroll">Time is Running Out For Your Regular Idaho Driver&#8217;s License</a></div></article></div></section></div></div></div></main><aside class="main-aside" aria-label="sidebar"></aside></div><section class="site-footer"><footer id="site-footer" tabindex="-1"><div class="links clearfix"><div class="logo"></div><div class="details"><h2>Information</h2><ul><li class=""><a href="/eeo/" aria-label="EEO">EEO</a></li><li class=""><a href="/advertising-and-marketing-for-business/boise-id/" aria-label="Marketing and Advertising Solutions">Marketing and Advertising Solutions</a></li><li class="next-one-merge"><a href="https://publicfiles.fcc.gov/fm-profile/KXLT-FM" aria-label="KXLTFM Public File">Public File</a></li><li class="last-one-merge"><a href="/kxlt-public-file/" aria-label="Persons with disabilities who need assistance with the KXLTFM / KXLT Public File">Need Assistance</a></li><li class=""><a href="/fcc-applications/" aria-label="FCC Applications">FCC Applications</a></li><li class=""><a href="/report-an-inaccuracy" aria-label="Report an Inaccuracy">Report an Inaccuracy</a></li><li class=""><a href="/terms/" aria-label="Terms">Terms</a></li><li class=""><a href="/contest-rules/" aria-label="Contest Rules">Contest Rules</a></li><li class=""><a href="/privacy/" aria-label="Privacy Policy">Privacy Policy</a></li><li class=""><a href="/digital-accessibility-statement/" aria-label="Accessibility Statement">Accessibility Statement</a></li><li class=""><a href="/privacy/preferences/" aria-label="Exercise My Data Rights">Exercise My Data Rights</a></li><li class=""><a href="/help/" aria-label="Contact">Contact</a></li><li class=""><a href="/boise-featured-business-listings/" aria-label="Boise Business Listings">Boise Business Listings</a></li></ul></div><div class="social-links"><h2>Follow Us</h2><ul><li class="social"><a class="share_link youtube" href="https://www.youtube.com/user/1079litefm" target="_blank" rel="noopener noreferrer" data-social="youtube"><span class="visually-hidden">Visit us on Youtube</span></a></li><li class="social"><a class="share_link facebook" href="https://www.facebook.com/1079LiteBoise" target="_blank" rel="noopener noreferrer" data-social="facebook"><span class="visually-hidden">Visit us on Facebook</span></a></li><li class="social"><a class="share_link twitter" href="https://twitter.com/1079litefm" target="_blank" rel="noopener noreferrer" data-social="twitter"><span class="visually-hidden">Visit us on Twitter</span></a></li></ul></div></div><div class="legal">2022<!-- --> <!-- -->107.9 LITE FM<a href="https://www.townsquaremedia.com">, Townsquare Media, Inc</a>. All rights reserved.</div></footer></section></div><section class="bottom-components"><div id="bottom-not-ads"><div class="tsm-ad tsm-ad-728" aria-label="advertisement"><div id="tsm-ad-728b"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-interstitial" aria-label="advertisement"><div id="tsm-ad-interstitial"><!-- dynamic ad --></div></div></div></section></div></div></div>
          <script style="display: none;">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</script>
          
          
          
          
          
          
          
          
          
          
          
          <script type="text/javascript">
      window._taboola = window._taboola || [];
      _taboola.push({flush: true});
    </script>
          <script>(function(d){
            var getFile = window.TSM.fn.getFile;
            try{
              let
                getDependencies = function(){
                  return new Promise(async function( res, rej ){
                    var dependencies = ["//townsquare.media/public/dist/desktop/main.bundle.2730341c0d44b114044f211b0334540c1ec67ae6.js?mver=102&gver=3"];
                    for(var i=0;i<dependencies.length;i++){
                      await getFile( dependencies[i] );
                    }
                    res({});
                  });
                },
                getInitialState = function(){
                  return fetch( [ location.pathname, location.search, ( location.search ? "&" : "?" ), "initialState=2730341c0d44b114044f211b0334540c1ec67ae6" ].join( "" ) )
                    .then( response => {
                      if( !response.ok ){
                        if( response.status === 404 ){
                          return response;
                        }
                        throw Error( response.statusText );
                      }
                      return response;
                    })
                    .then( response => response.json() )
                    .catch(( err )=>{
                      console.log( "Carbon - Error in Rest response", err );
                    });
                };
              let allTasks = [ getDependencies() ];Promise.all( allTasks )
                  .then(function(results){
                    window.initCarbon && window.initCarbon();
                  });
            }catch(e){console.error(e);}
          })(document);</script>
          
        </body>
      </html>