<!doctype html>
      <html class="single desktop layout-clean fixed-full-width" lang="en">
        <head>
          <title>Talented Idahoans Who Got National Attention on Contestant Shows</title>
          <meta http-equiv="Content-Type" content="text/html;charset=UTF-8"/><meta charset="UTF-8"/><meta name="instagram_profile" value="1079litefm"/><meta name="description" content="From American Idol to The Voice to Americas Got Talent. What Idahoans have performed on the big stage in front of the US to try and out stay the competition?"/><meta name="keywords" content="the voice, voice, american, american idol, contest, singing, sing, win, winner, idaho, idahoans on national competition shows, famous idahoans, people from idaho, ,entertainment,on-air"/><meta property="fb:app_id" content="151245606939829"/><meta property="fb:admins" content="100002025987268"/><meta property="fb:use_automatic_ad_placement" content="false"/><meta property="og:title" content="Talented Idahoans Who Got National Attention on Contestant Shows"/><meta property="og:description" content="From American Idol to The Voice to Americas Got Talent. What Idahoans have performed on the big stage in front of the US to try and out stay the competition?"/><meta property="og:url" content="https://liteonline.com/talented-idahoans-who-got-national-attention-on-contestant-shows/"/><meta property="og:site_name" content="107.9 LITE FM"/><meta property="og:type" content="article"/><meta property="og:image:width" content="1200"/><meta property="og:image:height" content="630"/><meta property="og:image" content="https://townsquare.media/site/660/files/2019/07/GettyImages-130724667.jpg?w=1200&#x26;h=0&#x26;zc=1&#x26;s=0&#x26;a=t&#x26;q=89"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@1079litefm"/><meta name="sailthru.description" content="From American Idol to The Voice to Americas Got Talent. What Idahoans have performed on the big stage in front of the US to try and out stay the competition?"/><meta name="sailthru.date" content="2022-10-03 06:28:51"/><meta name="sailthru.title" content="Talented Idahoans Who Got National Attention on Contestant Shows"/><meta name="sailthru.tags" content="tsmsite-kxlt, tsmmarket-boise, tsmtype-local, american-idol, famous-idahoans, idahoans-on-national-competition-shows, newsletter, people-from-idaho, the-voice, entertainment, on-air"/><meta name="sailthru.author" content="nikkiwest"/><meta name="sailthru.image.full" content="https://townsquare.media/site/660/files/2019/07/GettyImages-130724667.jpg"/><meta name="sailthru.image.thumb" content="https://townsquare.media/site/660/files/2019/07/GettyImages-130724667.jpg"/><meta name="robots" content="max-image-preview:large"/><meta property="fb:pages" content="138647476157057"/>
          <link rel="preload" href="/styles/desktop/base.css?ver=0e0ff3338a9ed5329fce64f0d70036f501d56bb3&mver=102&gver=3" as="style"/><link rel="preload" href="//townsquare.media/public/dist/desktop/main.bundle.0e0ff3338a9ed5329fce64f0d70036f501d56bb3.js?mver=102&gver=3" as="script"/><link rel="preconnect" href="https://btloader.com" crossorigin /><link rel="preconnect" href="https://action.dstillery.com" crossorigin /><link rel="preconnect" href="https://px.owneriq.net" crossorigin /><link rel="preconnect" href="https://cdn.taboola.com" crossorigin />
          <link id="design-fav" rel="shortcut icon" href="https://townsquare.media/site/660/files/2018/03/LiteFavilogo1.gif"/><link rel="profile" href="http://gmpg.org/xfn/11"/><link rel="prev" title="Idaho Billionaire Buys Up Hawaii, Locals Not Thrilled" href="https://liteonline.com/idaho-billionaire-buys-up-hawaii-locals-not-thrilled/"/><link rel="next" title="Men Aren’t Going To Like How Boise Women REALLY Feel About Them" href="https://liteonline.com/men-arent-going-to-like-how-boise-women-really-feel-about-them/"/><link rel="canonical" href="https://mix106radio.com/talented-idahoans-who-got-national-attention-on-contestant-shows/"/><link rel="apple-touch-icon-precomposed" href="https://townsquare.media/wp-content/uploads/2019/05/KXLTFM.png?w=57&h=57"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://townsquare.media/wp-content/uploads/2019/05/KXLTFM.png?w=144&h=144"/><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://townsquare.media/wp-content/uploads/2019/05/KXLTFM.png?w=72&h=72"/>
          <!-- <link href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap" rel="stylesheet" type="text/css" /> -->
          <!-- connect to domain of font files -->
          <link rel="preconnect" href="https://fonts.googleapis.com" crossorigin/>
          <!-- optionally increase loading priority -->
          <link rel="preload" as="style" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap">
          <!-- async CSS -->
          <link rel="stylesheet" media="print" onload="this.onload=null;this.removeAttribute('media');" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap">
          <!-- no-JS fallback -->
          <noscript>
            <link rel="stylesheet" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap">
          </noscript>
          <link href="/styles/desktop/base.css?ver=0e0ff3338a9ed5329fce64f0d70036f501d56bb3&mver=102&gver=3" rel="stylesheet" type="text/css" />
          <script>window.TSM = window.TSM ||{}; window.TSM.fn = window.TSM.fn || {}; window.TSM.fn.isIe = function(n){var t,i;return(n=n||"",!n||n===null||typeof n=="undefined"||n&&!n.match)?!1:(t=n.match(/MSIEs([d.]+)/i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):(t=n.match(/Trident.*rv[ :]*(11)./i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):!1};
      window.TSM.fn.getFile=function(n,t={},i=document.body){return new Promise(function(r){var e=function(n){n.target.removeEventListener("load",e);r(n.target)},u=document.createElement("script"),f;u.addEventListener("load",e);u.src=n;for(f in t)u.setAttribute(f,t[f]);i.appendChild(u)})};
      window.TSM.fn.getCookie = window.TSM.fn.getCookie || function(n){var i="; "+document.cookie,t=i.split("; "+n+"=");if(t.length==2)return t.pop().split(";").shift()};
      window.TSM.fn.setCookie = window.TSM.fn.setCookie || function(n,t,i,r="/"){var f="",u;i&&(u=new Date,u.setTime(u.getTime()+i*864e5),f="; expires="+u.toUTCString());document.cookie=n+"="+(t||"")+f+"; path="+r};
    </script>
          <script>window.taskQ=[];</script>
          
        <script type="text/javascript">
          window.TSM = window.TSM || {q:[]};
          window.TSM.abgroup = "A";
          window.TSM.cadata = {"activeDomain":"liteonline.com","blogId":660,"method":"get_single","postId":187901,"crosspostBlogId":"659","crosspostPostId":"237468","postType":"post","postDateGmt":"2022-10-03 12:28:51.000+0000"};
          window.TSM.startload = new Date().getTime();
        </script>
          <script>
    (function () {
      function getCookie(name) {
        var value = "; " + document.cookie;
        var parts = value.split("; " + name + "=");
        if (parts.length == 2) return parts.pop().split(";").shift();
      }
      function updateCookie(name, value, expireDays) {
        let d = new Date();
        d.setTime(d.getTime() + (60*60*24*expireDays*1000));
        var expires = "expires="+ d.toUTCString();
        document.cookie = name + "=" + value + ";" + expires + ";path=/";
      }
      window.TSM = window.TSM || {};
      if (window.TSM.abgroup) {
        updateCookie("abgroup", window.TSM.abgroup, 90);
      }

      var xhr = new XMLHttpRequest();
      xhr.open("POST", "/rest/high/api/cogitoergosum", true);
      var cogitoergosum = getCookie("cogitoergosum");
      var abgroup = getCookie("abgroup");
      if (cogitoergosum) {
        window.TSM.cogitoergosum = JSON.parse( atob( decodeURIComponent( cogitoergosum ) ) );
      }
      xhr.onreadystatechange = function() {//Call a function when the state changes.
        if(xhr.readyState == XMLHttpRequest.DONE && xhr.status == 200) {
          if (xhr.response) {
            var result = JSON.parse(xhr.response);
            if (result && result.result) {
              if (result.result.cookie) {
                window.TSM.cogitoergosum = JSON.parse( atob( result.result.cookie ) );
              }
              if (result.result.credentials) {
                window.TSM.credentials = JSON.parse( atob( result.result.credentials ) );
              }
              // console.log("cogitoergosum xhr", window.TSM.cogitoergosum);
            }
          }
        }
      };
      xhr.setRequestHeader("Content-type", "application/json");
      var cadata = window.TSM.cadata || {};
      cadata.experimentGroup = window.TSM.abgroup;
      cadata.viewType = "standard";
      cadata.timespent = new Date().getTime() - window.TSM.startload;
      var referrer = document.referrer;
      var sendData = {
        type: "pageview",
        referrer: referrer,
        url: document.location.href,
        queryParam: document.location.queryParam,
        pageData: cadata,
        scrollPageIndex: 0
      };
      xhr.send(JSON.stringify(sendData));
    }());
  </script>
          <script>(function(w,d){
        const
          getCookie = w.TSM.fn.getCookie;
        let
          aleph = getCookie( "aleph" );
        if( aleph ){
          w.aleph = aleph;
        }
      })(window, document);</script>
          <script>
            (function(w){
              w.ga=w.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
              var gaInitData = {"hitType":"pageview","dimension1":"nikkiwest","dimension2":"entertainment,on-air","dimension3":"american-idol,famous-idahoans,idahoans-on-national-competition-shows,newsletter,people-from-idaho,the-voice,mix106radio-xpost","dimension4":"post","dimension5":"Mon Oct 03 2022","dimension6":"06:28","dimension7":"standard","dimension8":"3427","dimension9":"A","dimension10":"yes","dimension12":"","dimension13":"","dimension14":"","dimension15":"","dimension16":""};
gaInitData.dimension13=function(){let refData=sessionStorage.getItem("itemRef"),str=[];return refData&&(refData=JSON.parse(refData),refData.title&&(str.push(refData.title),str.push(refData.source||"NA")),sessionStorage.removeItem("itemRef"),window.opener&&window.opener.sessionStorage&&window.opener.sessionStorage.removeItem("itemRef")),str.join(" -|- ");}();
gaInitData.dimension15=window.aleph || "";
gaInitData.dimension16=navigator.userAgent || "";
window.globalDimensionData = {"dimension1":"nikkiwest","dimension2":"entertainment,on-air","dimension3":"american-idol,famous-idahoans,idahoans-on-national-competition-shows,newsletter,people-from-idaho,the-voice,mix106radio-xpost","dimension4":"post","dimension5":"Mon Oct 03 2022","dimension6":"06:28","dimension7":"standard","dimension8":"3427","dimension9":"A","dimension10":"yes","dimension12":"","dimension13":"","dimension14":"","dimension15":"","dimension16":""};
window.globalDimensionData.dimension15=window.aleph || "";
ga( "create", {
          trackingId:"UA-45254601-8",
          name: "primary",
          allowAnchor: false
        });
        
        ga( "primary.require", "displayfeatures" );
        ga( "primary.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "primary.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "primary" ] = {gaid:"UA-45254601-8"};
ga( "create", {
          trackingId:"UA-19109753-1",
          name: "UA191097531",
          allowAnchor: false
        });
        
        ga( "UA191097531.require", "displayfeatures" );
        ga( "UA191097531.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA191097531.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA191097531" ] = {gaid:"UA-19109753-1"};
ga( "create", {
          trackingId:"UA-45254601-2",
          name: "UA452546012",
          allowAnchor: false
        });
        
        ga( "UA452546012.require", "displayfeatures" );
        ga( "UA452546012.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA452546012.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA452546012" ] = {gaid:"UA-45254601-2"};
ga( "create", {
          trackingId:"UA-28825804-1",
          name: "UA288258041",
          allowAnchor: false
        });
        
        ga( "UA288258041.require", "displayfeatures" );
        ga( "UA288258041.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA288258041.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA288258041" ] = {gaid:"UA-28825804-1"};
ga( "create", {
          trackingId:"UA-45260060-5",
          name: "UA452600605",
          allowAnchor: false
        });
        
        ga( "UA452600605.require", "displayfeatures" );
        ga( "UA452600605.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA452600605.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA452600605" ] = {gaid:"UA-45260060-5"};
ga( "create", {
          trackingId:"UA-180756957-2",
          name: "UA1807569572",
          allowAnchor: false
        });
        
        ga( "UA1807569572.require", "displayfeatures" );
        ga( "UA1807569572.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA1807569572.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA1807569572" ] = {gaid:"UA-180756957-2"};
            })(window);
          </script>
          <script async defer src="https://www.google-analytics.com/analytics.js"></script>
          <script async defer src="//townsquare.media/public/resources/js/autotrack.carbon.js"></script>
          <script>(function(w){
      w.dataLayer = [{"title":"Talented Idahoans Who Got National Attention on Contestant Shows","callsign":"KXLTFM","market":"Boise","sitetype":"Local","siteClassification":"Local","state":"ID","genre":"pop,classic-hits","pageType":"post","tags":"american-idol,famous-idahoans,idahoans-on-national-competition-shows,newsletter,people-from-idaho,the-voice,mix106radio-xpost","categories":"entertainment,on-air","mediaType":"gallery","aleph":"","userAgent":""}];
      w.dataLayer[0].referer = document.referrer;w.dataLayer[0].curatedReferer = document.referrer.replace( /https?:\/\//, "" );w.dataLayer[0].dayOfWeek = function(n){return n.toLocaleString("en-US",{weekday:"long"})}(new Date);w.dataLayer[0].periodOfDay = function(n,t,i){t=n.getHours(),i=n.getMinutes(),i<10&&(i="0"+i);var r=parseInt(t+""+i);return r>=0&&r<600?"Overnight":r>=600&&r<1e3?"Morning Drive":r>=1e3&&r<1500?"Midday":r>=1500&&r<1900?"Afternoon Drive":r>=1900&&r<2400?"Evening":void 0}(new Date);
    })(window);</script>
          <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start": new Date().getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!="dataLayer"?"&l="+l:"";j.async=true;j.src= "https://www.googletagmanager.com/gtm.js?id="+i+dl;f.parentNode.insertBefore(j,f); })(window,document,"script","dataLayer","GTM-K346HJZ");});</script>
          
        <script>
        window.taskQ=window.taskQ||[];window.taskQ.push(function(){
          (function(w,dl){
            var
              isUS = RegExp( "us-region-source=CA" ).exec( document.cookie );
            const
              addOipScript = function(){
                if( dl && dl[0] ){
                  dl = dl[0];
                  w._oiqq = w._oiqq || [];
                  var keywordMeta = document.querySelector( "meta[name='keywords']");
                  _oiqq.push(["oiq_addPageBrand", "title:" + dl.title]);
                  _oiqq.push(["oiq_addPageBrand", "domain:" + location.hostname]);
                  _oiqq.push(["oiq_addPageBrand", "callsign:" + dl.callsign]);
                  _oiqq.push(["oiq_addPageCat", "url_path:" + location.pathname]);
                  _oiqq.push(["oiq_addPageCat", "meta_keywords:" + ( keywordMeta ? keywordMeta.content : "" ) ]);
                  _oiqq.push(["oiq_addPageCat", "title:" + dl.title]);
                  _oiqq.push(["oiq_addPageCat", "callsign:" + dl.callsign]);
                  _oiqq.push(["oiq_addPageCat", "market:" + dl.market]);
                  _oiqq.push(["oiq_addPageCat", "sitetype:" + dl.sitetype]);
                  _oiqq.push(["oiq_addPageCat", "state:" + dl.state]);
                  _oiqq.push(["oiq_addPageCat", "page_type:" + dl.pageType]);
                  _oiqq.push(["oiq_addPageCat", "media_type:" + dl.mediaType]);
                  _oiqq.push(["oiq_addPageCat", "day_of_week:" + dl.dayOfWeek]);
                  _oiqq.push(["oiq_addPageCat", "newsletter_submission:" + (dl.newsletterSubmission || "no")]);
                  _oiqq.push(["oiq_addPageCat", "period_of_day:" + dl.periodOfDay]);
                  _oiqq.push(["oiq_addPageCat", "curated_referer:" + dl.curatedReferer]);
                  _oiqq.push(["oiq_addPageCat", "genre:" + dl.genre]);
                  _oiqq.push(["oiq_addPageCat", "tags:" + dl.tags]);
                  _oiqq.push(["oiq_addPageCat", "categories:" + dl.categories]);
                  _oiqq.push(["oiq_doTag"]);
                  _oiqq.push(["oiq_addPageLifecycle", "ecv3"]);
                }
                var oiq = document.createElement("script"); oiq.type = "text/javascript"; oiq.async = true; oiq.defer = true;
                oiq.src = document.location.protocol + "//px.owneriq.net/stas/s/0frxgz.js";
                var s = document.getElementsByTagName("script")[0]; s.parentNode.insertBefore(oiq, s);
              },
              callback =  (tcData, success) => {
                if(success && tcData.eventStatus === 'tcloaded') {
                  if( !tcData.gdprApplies || ( tcData.gdprApplies && tcData.tcString ) ){
                    addOipScript();
                  }
                  __tcfapi('removeEventListener', 2, (success) => {}, tcData.listenerId );
                }
              };
            __tcfapi( "addEventListener", 2, callback );
          })(window, window.dataLayer);
        });
      </script>
        
        
        
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
      (function (d, t) {
        var g = d.createElement(t), s = d.getElementsByTagName(t)[0];
        g.type='text/javascript';
        g.async = true;
        g.defer = true;
        g.src = 'https://btloader.com/tag?o=5642230212591616&upapi=true';
        s.parentNode.insertBefore(g, s)
      }(document, 'script'));
    });</script>
        
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
        window.TSM.fn.getFile("https://action.dstillery.com/orbserv/nsjs?adv=cl1016361&ns=3141&nc=KXLTFM&ncv=24", {"async": "async", "defer": "defer"});
        window.TSM.fn.getFile("https://action.dstillery.com/orbserv/nsjs?adv=cl1016361&ns=3141&nc=all_tsm_sv&ncv=24", {"async": "async", "defer": "defer"});
      });</script>
        
        
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
      (function (d, t) {
        var g = d.createElement(t), s = d.getElementsByTagName(t)[0];
        g.type='text/javascript';
        g.async = true;
        g.defer = true;
        g.src = '//townsquare.media/public/resources/js/pubcid.min.js';
        s.parentNode.insertBefore(g, s)
      }(document, 'script'));
    });</script>
          
          
          <script>//gdpr 2 - tcfapi stub
      ;!function(){var e=function(){var e,t="__tcfapiLocator",a=[],n=window;for(;n;){try{if(n.frames[t]){e=n;break}}catch(e){}if(n===window.top)break;n=n.parent}e||(!function e(){var a=n.document,r=!!n.frames[t];if(!r)if(a.body){var i=a.createElement("iframe");i.style.cssText="display:none",i.name=t,a.body.appendChild(i)}else setTimeout(e,5);return!r}(),n.__tcfapi=function(){for(var e,t=arguments.length,n=new Array(t),r=0;r<t;r++)n[r]=arguments[r];if(!n.length)return a;if("setGdprApplies"===n[0])n.length>3&&2===parseInt(n[1],10)&&"boolean"==typeof n[3]&&(e=n[3],"function"==typeof n[2]&&n[2]("set",!0));else if("ping"===n[0]){var i={gdprApplies:e,cmpLoaded:!1,cmpStatus:"stub"};"function"==typeof n[2]&&n[2](i)}else a.push(n)},n.addEventListener("message",(function(e){var t="string"==typeof e.data,a={};try{a=t?JSON.parse(e.data):e.data}catch(e){}var n=a.__tcfapiCall;n&&window.__tcfapi(n.command,n.version,(function(a,r){var i={__tcfapiReturn:{returnValue:a,success:r,callId:n.callId}};t&&(i=JSON.stringify(i)),e.source.postMessage(i,"*")}),n.parameter)}),!1))};"undefined"!=typeof module?module.exports=e:e()}();</script><script>
      window.cmpFactory = function( varName ) {
        var
          listen = window.attachEvent || window.addEventListener,
          isDebug = RegExp( "debug=([^&]+)" ).exec( location.search );
        listen('message', function(event) {
          window[ varName ].receiveMessage && window[ varName ].receiveMessage(event);
        });

        var commandQueue = [];
        var cmp = function(command, parameter, callback) {
          if( command === "ping" ){
            callback({cmpLoaded: false}, true);
          }else{
            commandQueue.push({
              command: command,
              parameter: parameter,
              callback: callback
            });
          }
        };
        cmp.commandQueue = commandQueue;
        cmp.receiveMessage = function(event) {
          var data = event && event.data && event.data[ varName + "Call" ];
          if (data) {
            commandQueue.push({
              callId: data.callId,
              command: data.command,
              parameter: data.parameter,
              event: event
            });
          }
        };
        cmp.config = {};
        if( isDebug && isDebug[1] && isDebug[1] === "YES" ){
          cmp.config.logging = "debug";
        }
        return cmp;
      };
      window.__cmp = window.cmpFactory( "__cmp" );
      window.__uspapi = window.cmpFactory( "__uspapi" );
    </script><script>
      (function(w) {
        w.TSM.fn.getFile( "//townsquare.media/public/resources/js/cmp.bundle.js", {}, document.head );
        w.cnvr_launcher_options={lid:336};
        w.TSM.fn.getFile( "https://secure.cdn.fastclick.net/js/cnvr-launcher/latest/launcher-stub.min.js", {}, document.head );
      })(window);
    </script>
          <link rel="preconnect" href="https://doi3unldljdx6.cloudfront.net." crossorigin/><script type="text/javascript" src="//doi3unldljdx6.cloudfront.net./script.js" async></script><script async type="text/javascript" src="https://native.sharethrough.com/assets/sfp.js"></script><script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
        <script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        </script>
<script async src="//js-sec.indexww.com/ht/p/186854-113710634486999.js"></script>
<script>window.pbjs=window.pbjs||{};window.pbjs.que=window.pbjs.que||[];window.PREBID_TIMEOUT=2000;</script>
<script src="https://cdn.production.townsquareblogs.com/wp-content/uploads/static/prebid/carbon/pb.js?domain=liteonline.com&v=0e0ff3338a9ed5329fce64f0d70036f501d56bb3&mver=102&gver=3" ></script>

<script>(function(){!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
        var params={pubID:"3227",adServer:"googletag",params:{us_privacy: (RegExp( "usprivacy=([^;]+)" ).exec( document.cookie ) || [])[1] || "1---"}};apstag.init(params);})();</script>


<script>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</script>
          <script defer src="https://apis.google.com/js/platform.js"></script>
      <script>window.twttr = (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0],
        t = window.twttr || {};
      if (d.getElementById(id)) return t;
      js = d.createElement(s);
      js.id = id;
      js.src = "https://platform.twitter.com/widgets.js";
      fjs.parentNode.insertBefore(js, fjs);
      t._e = [];
      t.ready = function(f) {
        t._e.push(f);
      };
      return t;
    }(document, "script", "twitter-wjs"));
    (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id;
      js.src = "//connect.facebook.net/en_US/sdk.js";
      fjs.parentNode.insertBefore(js, fjs);
    }(document, "script", "facebook-jssdk"));</script>
    <script async defer src="//platform.instagram.com/en_US/embeds.js"></script>
    <script>var ZERG = ZERG || {};ZERG.domain = "liteonline.com";ZERG.user = 751;</script>
          <script type="text/javascript">
      window._taboola = window._taboola || [];
        _taboola.push({article:"auto"});
        !function (e, f, u, i) {
          if (!document.getElementById(i)){
            e.async = 1;
            e.src = u;
            e.id = i;
            f.parentNode.insertBefore(e, f);
          }
        }(document.createElement("script"),
          document.getElementsByTagName("script")[0],
          "//cdn.taboola.com/libtrc/townsquaremediatsm-network/loader.js",
          "tb_loader_script");
        if(window.performance && typeof window.performance.mark == "function")
        {window.performance.mark("tbl_ic");}
    </script>
          <script type="application/ld+json">{"@context":"https://schema.org","@graph":[{"@context":"https://schema.org/","@type":"NewsMediaOrganization","@id":"https://liteonline.com/#organization","name":"107.9 LITE FM","logo":{"@type":"ImageObject","@id":"https://liteonline.com/#sitelogo","url":"//townsquare.media/site/660/files/2015/11/logo.png"},"sameAs":["https://liteonline.com/"]},{"@context":"http://schema.org/","@type":"Website","@id":"https://liteonline.com/#website","publisher":{"@id":"https://liteonline.com/#organization"},"name":"107.9 LITE FM","url":"https://liteonline.com/"},{"@context":"https://schema.org","@type":"article","headline":"Talented Idahoans Who Got National Attention on Contestant Shows","publisher":{"@id":"https://liteonline.com/#organization"},"url":"https://liteonline.com/talented-idahoans-who-got-national-attention-on-contestant-shows/","mainEntityOfPage":{"@type":"WebPage","@id":"https://mix106radio.com/talented-idahoans-who-got-national-attention-on-contestant-shows/"},"description":"From American Idol to The Voice to Americas Got Talent. What Idahoans have performed on the big stage in front of the US to try and out stay the competition?","@id":"https://liteonline.com/talented-idahoans-who-got-national-attention-on-contestant-shows/#article","image":"//townsquare.media/site/660/files/2019/07/GettyImages-130724667.jpg","author":{"@type":"Person","name":"Nikki West","sameAs":"https://mix106radio.com/author/nikkiwest"},"keywords":["the voice","voice","american","american idol","contest","singing","sing","win","winner","idaho","idahoans on national competition shows","famous idahoans","people from idaho","entertainment","on-air"],"datePublished":"2022-10-03T10:28:51.000Z","dateCreated":"2022-10-03T10:28:51.000Z","dateModified":"2022-10-03T10:28:51.000Z","isPartOf":{"@id":"https://liteonline.com/#website"}}]}</script>
        </head>
        <body>
          <script>(function(w,d){
        const
          getCookie = window.TSM.fn.getCookie,
          setCookie = window.TSM.fn.setCookie;
        let
          aleph = getCookie( "aleph" );
        if( aleph ){
          w.aleph = aleph;
        }else{
          w.addEventListener("message", (e) => {
            //console.log(e);
            if( e.data && e.data.aleph ){
              //console.log( "e.data.aleph", e.data.aleph );
              window.aleph = e.data.aleph;
              window.cQ = window.cQ || [];
              window.cQ.push(()=>{
                window.globalActionCreators && window.globalActionCreators.addAleph && window.globalActionCreators.addAleph( window.aleph )
              });
              setCookie( "aleph", e.data.aleph, 365*2 );
            }
          });
          let
            ifr = d.createElement( "iframe" );
          ifr.id = "aleph-iframe";
          ifr.title = "aleph";
          ifr.src = "https://cdn.production.townsquareblogs.com/aleph/";
          ifr.frameborder = "0";
          ifr.style = "display:none;"
          ifr.addEventListener("load", ()=>{
            ifr.contentWindow.postMessage({action: "getAleph"}, "https://cdn.production.townsquareblogs.com");
          });
          d.body.appendChild( ifr );
        }
      })(window, document);</script>
          <div id="fb-root"></div>
          <div id="app">
          <div><header id="site-menu-wrapper" class="leaderboard-style-default" aria-label="site header"><div id="skip-to-main"><a href="#main-content">Skip to main content</a><a href="#site-footer">Skip to site footer</a></div><div class="site-menu-drawer"><ul class="promo-links" aria-label="promoted links"><li><span>Trending:</span></li><li><a href="/win-cash-fall-2022/">Win $30K With the Payroll Payout</a></li><li><a href="/tags/halloween-2022/">Halloween 2022</a></li><li><a href="/feed-your-office-with-lite-fms-doughnut-dash-2/">Doughnut Dash</a></li><li><a href="/the-new-107-9-lite-fm-app-is-here-download-it-now-to-win/">LITE App</a></li><li><a href="/tags/boise-eats">Boise Eats</a></li><li><a href="/tags/boise-luxury-homes">Boise Luxury Homes</a></li><li><a href="/tags/road-trip-worthy/">Idaho Road Trip Planner</a></li></ul></div><div id="site-menu-bg"></div><div class="logo-next-to-logo-container"><a class="logo" itemProp="logo url" href="/" data-source="logo"><img src="//townsquare.media/site/660/files/2018/08/liteonline-logo-v21.png" alt="107.9 LITE FM"/></a><div class="next-to-logo"><div class="non-menu-content"><div class="admin-bar-wrap"></div><div class="tsm-ad tsm-ad-728" aria-label="advertisement"><div id="tsm-ad-728a"><!-- dynamic ad --></div></div></div><nav id="site-menu" class="hide-overflow" aria-label="primary navigation"><div class="wrapper"><span class="icon-menu"></span><div class="showticker-container" id="show-ticker"><div class="slider showticker-items"><div class="sizer"></div><div class="mover fade"><div id="promotion-22" class="stationtagline-container showticker-item"><div class="content"><a class="info" href="#">THE BEST VARIETY OF THE 80s, 90s, AND TODAY</a></div></div></div></div></div><ul class="links"><li class="hassub"><a href="/" data-source="nav">Home</a></li><li class="hassub"><a href="/djs" data-source="nav">DJs</a><ul class="links submenu"><li class="hassub"><a href="/djs" data-source="nav">All DJs</a></li><li class="hassub"><a href="/shows" data-source="nav">Schedule</a></li><li class="hassub"><a href="/author/michelleheart" data-source="nav">Michelle Heart</a></li><li class="hassub"><a href="/author/chrispickett/" data-source="nav">Marco</a></li><li class="hassub"><a href="/author/austinjen" data-source="nav">Jen Austin</a></li><li class="hassub"><a href="/author/bdelilah/" data-source="nav">Delilah</a></li><li class="hassub"><a href="/author/chris" data-source="nav">Chris</a></li></ul></li><li class="hassub"><a href="/listen-live" data-source="nav">Listen</a><ul class="links submenu"><li class="hassub"><a href="/listen-live" data-source="nav">Listen Live</a></li><li class="hassub"><a href="/alexa" data-source="nav">Alexa</a></li><li class="hassub"><a href="/googlehome" data-source="nav">Google Home</a></li><li class="hassub"><a href="/playlist" data-source="nav">Recently Played</a></li></ul></li><li class="hassub"><a href="/app" data-source="nav">App</a><ul class="links submenu"><li class="hassub"><a href="/download/ios" data-source="nav">Download iOS</a></li><li class="hassub"><a href="/download/android" data-source="nav">Download Android</a></li></ul></li><li class="hassub"><a href="/contests" data-source="nav">Win Stuff</a><ul class="links submenu"><li class="hassub"><a href="/win-cash-fall-2022/" data-source="nav">Payroll Payout: Win a $30K</a></li><li class="hassub"><a href="/michael-buble-in-la/" data-source="nav">See Michael Bublé in LA</a></li><li class="hassub"><a href="/registration" data-source="nav">Sign Up</a></li><li class="hassub"><a href="/contest-rules/" data-source="nav">Rules</a></li><li class="hassub"><a href="/help" data-source="nav">Contest Support</a></li></ul></li><li class="hassub"><a href="/help" data-source="nav">Contact</a><ul class="links submenu"><li class="hassub"><a href="/help" data-source="nav">Help &amp; Contact Info</a></li><li class="hassub"><a href="/feedback" data-source="nav">Send Feedback</a></li><li class="hassub"><a href="/advertise" data-source="nav">Advertise</a></li></ul></li><li class="hidden-menu hassub hide"><div class="more-icon link" aria-hidden="true">More</div><ul class="links submenu"><li class="hassub hide"><a href="/" data-source="nav">Home</a></li><li class="hassub hide"><a href="/djs" data-source="nav">DJs</a><ul class="links submenu"><li class="hassub"><a href="/djs" data-source="nav">All DJs</a></li><li class="hassub"><a href="/shows" data-source="nav">Schedule</a></li><li class="hassub"><a href="/author/michelleheart" data-source="nav">Michelle Heart</a></li><li class="hassub"><a href="/author/chrispickett/" data-source="nav">Marco</a></li><li class="hassub"><a href="/author/austinjen" data-source="nav">Jen Austin</a></li><li class="hassub"><a href="/author/bdelilah/" data-source="nav">Delilah</a></li><li class="hassub"><a href="/author/chris" data-source="nav">Chris</a></li></ul></li><li class="hassub hide"><a href="/listen-live" data-source="nav">Listen</a><ul class="links submenu"><li class="hassub"><a href="/listen-live" data-source="nav">Listen Live</a></li><li class="hassub"><a href="/alexa" data-source="nav">Alexa</a></li><li class="hassub"><a href="/googlehome" data-source="nav">Google Home</a></li><li class="hassub"><a href="/playlist" data-source="nav">Recently Played</a></li></ul></li><li class="hassub hide"><a href="/app" data-source="nav">App</a><ul class="links submenu"><li class="hassub"><a href="/download/ios" data-source="nav">Download iOS</a></li><li class="hassub"><a href="/download/android" data-source="nav">Download Android</a></li></ul></li><li class="hassub hide"><a href="/contests" data-source="nav">Win Stuff</a><ul class="links submenu"><li class="hassub"><a href="/win-cash-fall-2022/" data-source="nav">Payroll Payout: Win a $30K</a></li><li class="hassub"><a href="/michael-buble-in-la/" data-source="nav">See Michael Bublé in LA</a></li><li class="hassub"><a href="/registration" data-source="nav">Sign Up</a></li><li class="hassub"><a href="/contest-rules/" data-source="nav">Rules</a></li><li class="hassub"><a href="/help" data-source="nav">Contest Support</a></li></ul></li><li class="hassub hide"><a href="/help" data-source="nav">Contact</a><ul class="links submenu"><li class="hassub"><a href="/help" data-source="nav">Help &amp; Contact Info</a></li><li class="hassub"><a href="/feedback" data-source="nav">Send Feedback</a></li><li class="hassub"><a href="/advertise" data-source="nav">Advertise</a></li></ul></li></ul></li></ul><div class="site-menu-right"><a class="listen-live-cto cto" style="min-width:300px"></a><ul class="social-links"><li class="social"><a class="share-link youtube" href="https://youtube.com/user/1079litefm" target="_blank" rel="noopener noreferrer" data-social="youtube"><span class="visually-hidden">Visit us on Youtube</span></a></li><li class="social"><a class="share-link facebook" href="https://www.facebook.com/1079LiteBoise" target="_blank" rel="noopener noreferrer" data-social="facebook"><span class="visually-hidden">Visit us on Facebook</span></a></li><li class="social"><a class="share-link twitter" href="https://twitter.com/1079litefm" target="_blank" rel="noopener noreferrer" data-social="twitter"><span class="visually-hidden">Visit us on Twitter</span></a></li><li><ul class="social-subscriptions"><li class="sub-instagram "><a href="https://www.instagram.com/1079litefm" target="_blank" rel="noopener noreferrer">INSTAGRAM</a></li><li class="share_link_small youtube sub-youtube"></li><li class="sub-facebook"></li><li class="sub-twitter"></li></ul></li></ul><div id="search-form" class=""><div class="form-wrap"></div><div class="icon-base icon-search"></div></div></div><div class="site-screen select-none"></div></div></nav></div></div></header><div id="container" class=""><div id="top-not-ads" class=""><div id="tsm-ad-1x1-container"><div class="tsm-ad tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-oop"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-oop2"><!-- dynamic ad --></div></div></div></div><div class="tsm-ad tsm-ad-nav-970" aria-label="advertisement"><div id="tsm-ad-970a"><!-- dynamic ad --></div></div><div class="container-inner"><div class="site-content clearfix"><main id="main-content" class="main-content" tabindex="-1"><div class="wrapper post-wrapper"><div class="internal-header outgrow " style="max-height:0px"></div><div class="post clearfix"><div class="entry"><article id="post-187901" data-location="/talented-idahoans-who-got-national-attention-on-contestant-shows/" data-index="0" class=""><div class="page-header"><div class="content-header show-ui front" id="content-header-187901"><div class="content-header-header"><div class="react-parallax"><figure class="frameme temp-ssr" alt="Talented Idahoans Who Got National Attention on Contestant Shows"><img src="//townsquare.media/site/660/files/2019/07/GettyImages-130724667.jpg?w=980&amp;q=75" alt="Talented Idahoans Who Got National Attention on Contestant Shows"/></figure></div><div class="header"><section class="title "><h1 class="">Talented Idahoans Who Got National Attention on Contestant Shows</h1></section><div class="byline"><div class="author-image"><div class="icon-user" aria-hidden="true"></div><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/657/files/2020/07/Nikki_Profile_07.07.20201.jpg" href="//liteonline.com/author/nikkiwest/" rel="author"><figcaption class="visually-hidden">Nikki West</figcaption></a></figure></div><div class="not-author-image-stuff"><div class="not-author-image-stuff-row"><a class="author-name" href="//liteonline.com/author/nikkiwest/" rel="author">Nikki West</a><time dateTime="2022-10-03 12:28:51 +0000">Published: October 3, 2022</time></div></div></div><figcaption>Kevin Winter, Getty Images</figcaption></div></div></div></div><div class="content-wrap"><div class="social-share bignsexy"><div class="social-bar social-icons"><ul><li><a href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fliteonline.com%2Ftalented-idahoans-who-got-national-attention-on-contestant-shows%2F%3Ftrackback%3Dfbshare_mobile" title="Share on Facebook" target="_blank"><span class=" social-icon icon-facebook fb"><span class="share-title">Share on Facebook</span></span></a></li><li><a href="http://twitter.com/intent/tweet?text=Talented%20Idahoans%20Who%20Got%20National%20Attention%20on%20Contestant%20Shows%20http%3A%2F%2Fliteonline.com%2Ftalented-idahoans-who-got-national-attention-on-contestant-shows%2F%3Ftrackback%3Dtwitter_mobile%20%401079litefm" title="Share on Twitter" target="_blank"><span class=" social-icon icon-twitter tw"><span class="share-title">Share on Twitter</span></span></a></li></ul></div></div><div class="content"><div class="pod-content"><p>We have a lot of talent here in the gem state. Idaho is home to some incredible&#xA0;people who have hit some of the biggest stages and performed in front of millions of people watching at home. Here are some of the top Idaho contestants from American Idol, The Voice and Americas Got Talent.</p><p>Idaho <strong>American Idol</strong> Contestants:</p><div class="in-article-oop-container sharethrough-container"><div class="tsm-ad tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-in-article-oop-1"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-1x1 tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-in-article-pixel-1"><!-- dynamic ad --></div></div></div><p><strong>Logan Johnson&#xA0;from Boise</strong>&#xA0;was on American Idol&#xA0;in&#xA0;2019.&#xA0;Logan graduated from Centennial High in 2016 and made it all the way to Hollywood Week on &#x201C;Idol&#x201D; after some memorably incredible performances.&#xA0;&#xA0;&#x201C;I think he&#x2019;s incredible,&#x201D; Luke Bryan&#xA0;said, &quot;I&#x2019;m seeing, like, this Timberlake thing.&#x201D; Logan has brought hope to a lot of people and continues to have a strong fan base. He is determined not to quit and keeps pumping out music.<br><iframe src="https://www.youtube.com/embed/OxNVUXo9fPw" width="560" height="315" frameborder="0"></iframe></p><p><strong>Amber Fiedler from Coeur d&#x2019;Alene</strong> had quite a ride on American Idol. She was very pregnant during audition. The redhead was carrying her baby to term and giving her up for adoption. She made it far enough for the Hollywood show, and even had to leave Idol to deliver the baby and come back. She was not able to make the top 20. Although based on the performance she gave in this video I would say she deserved it.<br><iframe src="https://www.youtube.com/embed/eh_8d5ez-20" width="560" height="315" frameborder="0"></iframe></p><p><strong>Maddie Zahm from Boise</strong>. Maddie was on American Idol in 2018 and as a teenager she brought the house down. Absolutely crushed it and what a heart she has.&#xA0;Maddie didn&apos;t come home the idol champion but she jump started a singing career anyway. With a large following Maddie is still singing as much as she can.<br><iframe src="https://www.youtube.com/embed/2K3ZhMvNOxQ" width="560" height="315" frameborder="0"></iframe></p><p>Idaho Contestants on <strong>The Voice:</strong></p><p><strong>Jacob Maxwell from Coeur D&apos;Alene</strong> was on The Voice in April of 2019. He comes from three generations of law enforcement and wanted to be a police officer until he picked up the guitar. At 13, he joined the worship team and started singing in church. He was on&#xA0;John Legend&#x2019;s Team. He made it to the top 24 before being sent home.&#xA0;<iframe src="https://www.youtube.com/embed/BmR1thUAMcM" width="560" height="315" frameborder="0"></iframe></p><p><strong>EllieMae&#xA0;Millenkamp from Jerome</strong>. 21-year old EllieMae grew up on her families ranch in Jerome Idaho. She was on The Voice in the fall of 2019 and was chosen to be on Team Blake. He was the only judge who turned during her audition and later said,&#xA0;&quot;EllieMae snuck in under the radar, but I&apos;m glad I&apos;m the only person who hit the button,&quot; Shelton said. &quot;She has the folky kind of sound to her that&apos;s kinda having a resurgence right now - with country and Americana - and I think she&apos;s gonna be a threat on this show.&quot;<br><iframe src="https://www.youtube.com/embed/v7OKTWPfUGk" width="560" height="315" frameborder="0"></iframe></p><p>Idaho Contestants on <strong>America&apos;s Got Talent</strong>:</p><p>The <strong>Summerwind Skippers</strong> <strong>from Boise</strong> made it to the semifinals on America&apos;s Got Talent back in 2011 for season 6.&#xA0;Summerwind Skippers were eliminated in the Quarterfinals, but they returned for the Wild Card Show. They were later eliminated again in the Semifinals.<br><iframe src="https://www.youtube.com/embed/aXjdyo0KzJA" width="560" height="315" frameborder="0"></iframe></p><p>We have to mention <strong>Boise&apos;s own David Rush</strong>. He was on American&apos;s Got Talent for about 5 minutes. He made it to the audition round and made it to TV. He is a great record setter but this one wasn&apos;t enough to advance him on.<br><iframe src="https://www.youtube.com/embed/6C5Wn6JrBSY" width="560" height="315" frameborder="0"></iframe></p><p>&#xA0;</p><p>Aside from the singing and talent competitions there are of course what seems like hundreds of contest shows out there. While I am only diving into the 3 main ones here I cant rightfully finish this post without mentioning <strong>Ben Driebergen from Boise</strong> who won a million dollars on Survivor&#xA0;Heroes vs. Healers vs. Hustlers in 2018.<br><iframe src="https://www.youtube.com/embed/lHyBvj8-PLM" width="560" height="315" frameborder="0"></iframe></p><p>&#xA0;</p><div class="photogallery-wrapper"><h2 class="photogallery-title">Boise State Student Featured on Good Morning America… [Video]</h2></div><div class="photogallery-wrapper"><h2 class="photogallery-title">Idaho's Homegrown NFL Talent </h2><div class="photogallery-description"><div>A look at Idaho players who have played in the NFL.</div></div></div><div class="photogallery-wrapper"><h2 class="photogallery-title">Adorable Home Remodeled on the Boise Boys' New TV Show For Sale</h2><div class="photogallery-description"><div>This cute home in Boise was featured in the episode "Layout Dysfunction" during Season 1 of the Boise Boys' <em>Outgrown. </em>Despite the great remodel, the family who lived here for years is selling it.</div></div></div></div></div><div class="content-footer"><div><div class="feed_attribution_after clearfix"> Source: <a href="//mix106radio.com/talented-idahoans-who-got-national-attention-on-contestant-shows/" target="_blank">Talented Idahoans Who Got National Attention on Contestant Shows</a>
</div></div><div class="tags-lines"><div class="wrapper tags"><span>Filed Under<!-- -->: </span><span><a href="//liteonline.com/tags/american-idol/">American Idol</a></span><span>, <a href="//liteonline.com/tags/famous-idahoans/">famous idahoans</a></span><span>, <a href="//liteonline.com/tags/idahoans-on-national-competition-shows/">idahoans on national competition shows</a></span><span>, <a href="//liteonline.com/tags/newsletter/">newsletter</a></span><span>, <a href="//liteonline.com/tags/people-from-idaho/">people from Idaho</a></span><span>, <a href="//liteonline.com/tags/the-voice/">The Voice</a></span></div><div class="wrapper categories"><span>Categories<!-- -->: </span><span><a href="//liteonline.com/category/entertainment/">Entertainment</a></span><span>, <a href="//liteonline.com/category/on-air/">On-Air</a></span></div></div><div class="comments-wrapper"><div class="comments"><div><i>Comments</i><span class="icon-triangle-down" aria-hidden="true"></span></div><div class="cto">Leave A Comment</div></div></div></div></div></article><div class="tsm-ad tsm-ad-728 tsm-ad-in-between-article" aria-label="advertisement"><div id="tsm-ad-728c-1"><!-- dynamic ad --></div></div><section id="ts_blogroll-afterpost" class="blogroll row-standard-3x ts_blogroll outgrow"><header class="header-band"><h2 class="">More From 107.9 LITE FM</h2></header><div class="blogroll-inner clearfix"><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/660/files/2022/10/attachment-69023490_10157230675355953_2745485654157688832_n.jpg" href="/best-resorts-2022/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Idaho Named Home of Three Best Resorts in the Western United States</figcaption></a></figure><div class="content"><a href="/best-resorts-2022/" class="title" data-source="blogroll">Idaho Named Home of Three Best Resorts in the Western United States</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/660/files/2022/10/attachment-gdgsdgsdg-36.jpg" href="/halloween-lights-map-2022/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Spooky Map Shows You How to Find the Best Halloween Displays in Boise</figcaption></a></figure><div class="content"><a href="/halloween-lights-map-2022/" class="title" data-source="blogroll">Spooky Map Shows You How to Find the Best Halloween Displays in Boise</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/659/files/2022/05/attachment-chris-child-nbavideoprovider.jpg" href="/boise-state-players-in-the-nba-2022/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Boise State&#8217;s Presence in the NBA Over The Years</figcaption></a></figure><div class="content"><a href="/boise-state-players-in-the-nba-2022/" class="title" data-source="blogroll">Boise State&#8217;s Presence in the NBA Over The Years</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/658/files/2022/05/attachment-pot2.jpg" href="/idaho-farm-generously-donates-10-million-pounds-of-potatoes/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Idaho Farm Generously Donates 10 Million Pounds of Potatoes!</figcaption></a></figure><div class="content"><a href="/idaho-farm-generously-donates-10-million-pounds-of-potatoes/" class="title" data-source="blogroll">Idaho Farm Generously Donates 10 Million Pounds of Potatoes!</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/660/files/2022/10/attachment-snow-view.jpg" href="/cave-airbnbs-near-boise/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Get Back To Basics In One Of These Amazing Cave Homes Near Boise</figcaption></a></figure><div class="content"><a href="/cave-airbnbs-near-boise/" class="title" data-source="blogroll">Get Back To Basics In One Of These Amazing Cave Homes Near Boise</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/657/files/2022/10/attachment-slc.jpg" href="/2-biggest-complaints-about-living-in-utah-do-you-agree-with-them/" rel="" data-source="blogroll"><figcaption class="visually-hidden">2 Biggest Complaints About Living in Utah, Do You Agree with Them?</figcaption></a></figure><div class="content"><a href="/2-biggest-complaints-about-living-in-utah-do-you-agree-with-them/" class="title" data-source="blogroll">2 Biggest Complaints About Living in Utah, Do You Agree with Them?</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/657/files/2022/10/attachment-vojtech-bruzek-Yrxr3bsPdS0-unsplash.jpg" href="/idahos-1-luxurious-hotel-ranks-as-one-of-the-best-in-america/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Idaho&#8217;s #1 Luxurious Hotel Ranks as One of the Best in America</figcaption></a></figure><div class="content"><a href="/idahos-1-luxurious-hotel-ranks-as-one-of-the-best-in-america/" class="title" data-source="blogroll">Idaho&#8217;s #1 Luxurious Hotel Ranks as One of the Best in America</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/204/files/2022/08/attachment-reba-the-hammer.jpg" href="/reba-mcentire-excited-to-return-to-nampa-where-it-all-began/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Reba McEntire Excited To Return Nampa Where It all Began</figcaption></a></figure><div class="content"><a href="/reba-mcentire-excited-to-return-to-nampa-where-it-all-began/" class="title" data-source="blogroll">Reba McEntire Excited To Return Nampa Where It all Began</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/659/files/2021/06/attachment-jeremy-zero-NWdI9BFnwoo-unsplash.jpg" href="/idaho-billionaire-buys-up-hawaii-locals-not-thrilled/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Idaho Billionaire Buys Up Hawaii, Locals Not Thrilled</figcaption></a></figure><div class="content"><a href="/idaho-billionaire-buys-up-hawaii-locals-not-thrilled/" class="title" data-source="blogroll">Idaho Billionaire Buys Up Hawaii, Locals Not Thrilled</a></div></article></div></section></div></div></div></main><aside class="main-aside" aria-label="sidebar"></aside></div><section class="site-footer"><footer id="site-footer" tabindex="-1"><div class="links clearfix"><div class="logo"></div><div class="details"><h2>Information</h2><ul><li class=""><a href="/eeo/" aria-label="EEO">EEO</a></li><li class=""><a href="/advertising-and-marketing-for-business/boise-id/" aria-label="Marketing and Advertising Solutions">Marketing and Advertising Solutions</a></li><li class="next-one-merge"><a href="https://publicfiles.fcc.gov/fm-profile/KXLT-FM" aria-label="KXLTFM Public File">Public File</a></li><li class="last-one-merge"><a href="/kxlt-public-file/" aria-label="Persons with disabilities who need assistance with the KXLTFM / KXLT Public File">Need Assistance</a></li><li class=""><a href="/fcc-applications/" aria-label="FCC Applications">FCC Applications</a></li><li class=""><a href="/report-an-inaccuracy" aria-label="Report an Inaccuracy">Report an Inaccuracy</a></li><li class=""><a href="/terms/" aria-label="Terms">Terms</a></li><li class=""><a href="/contest-rules/" aria-label="Contest Rules">Contest Rules</a></li><li class=""><a href="/privacy/" aria-label="Privacy Policy">Privacy Policy</a></li><li class=""><a href="/digital-accessibility-statement/" aria-label="Accessibility Statement">Accessibility Statement</a></li><li class=""><a href="/privacy/preferences/" aria-label="Exercise My Data Rights">Exercise My Data Rights</a></li><li class=""><a href="/help/" aria-label="Contact">Contact</a></li><li class=""><a href="/boise-featured-business-listings/" aria-label="Boise Business Listings">Boise Business Listings</a></li></ul></div><div class="social-links"><h2>Follow Us</h2><ul><li class="social"><a class="share_link youtube" href="https://www.youtube.com/user/1079litefm" target="_blank" rel="noopener noreferrer" data-social="youtube"><span class="visually-hidden">Visit us on Youtube</span></a></li><li class="social"><a class="share_link facebook" href="https://www.facebook.com/1079LiteBoise" target="_blank" rel="noopener noreferrer" data-social="facebook"><span class="visually-hidden">Visit us on Facebook</span></a></li><li class="social"><a class="share_link twitter" href="https://twitter.com/1079litefm" target="_blank" rel="noopener noreferrer" data-social="twitter"><span class="visually-hidden">Visit us on Twitter</span></a></li></ul></div></div><div class="legal">2022<!-- --> <!-- -->107.9 LITE FM<a href="https://www.townsquaremedia.com">, Townsquare Media, Inc</a>. All rights reserved.</div></footer></section></div><section class="bottom-components"><div id="bottom-not-ads"><div class="tsm-ad tsm-ad-728" aria-label="advertisement"><div id="tsm-ad-728b"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-interstitial" aria-label="advertisement"><div id="tsm-ad-interstitial"><!-- dynamic ad --></div></div></div></section></div></div></div>
          <script style="display: none;">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</script>
          
          
          
          
          
          
          
          
          
          
          
          <script type="text/javascript">
      window._taboola = window._taboola || [];
      _taboola.push({flush: true});
    </script>
          <script>(function(d){
            var getFile = window.TSM.fn.getFile;
            try{
              let
                getDependencies = function(){
                  return new Promise(async function( res, rej ){
                    var dependencies = ["//townsquare.media/public/dist/desktop/main.bundle.0e0ff3338a9ed5329fce64f0d70036f501d56bb3.js?mver=102&gver=3"];
                    for(var i=0;i<dependencies.length;i++){
                      await getFile( dependencies[i] );
                    }
                    res({});
                  });
                },
                getInitialState = function(){
                  return fetch( [ location.pathname, location.search, ( location.search ? "&" : "?" ), "initialState=0e0ff3338a9ed5329fce64f0d70036f501d56bb3" ].join( "" ) )
                    .then( response => {
                      if( !response.ok ){
                        if( response.status === 404 ){
                          return response;
                        }
                        throw Error( response.statusText );
                      }
                      return response;
                    })
                    .then( response => response.json() )
                    .catch(( err )=>{
                      console.log( "Carbon - Error in Rest response", err );
                    });
                };
              let allTasks = [ getDependencies() ];Promise.all( allTasks )
                  .then(function(results){
                    window.initCarbon && window.initCarbon();
                  });
            }catch(e){console.error(e);}
          })(document);</script>
          
        </body>
      </html>